Closed Bug 386350 Opened 16 years ago Closed 16 years ago

Sunbird fails to open several dialogs (Error: illegal character in applicationUtil.js)

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Using Sunbird 0.5pre (2007062823) I can't open several dialogs, e.g. Help -> About, Help -> Release Notes ...

Error Console shows:

Error: illegal character
Source File: chrome://calendar/content/applicationUtil.js
Line: 46
Source Code:
#ifdef XP_MACOSX

Error: openAboutDialog is not defined
Source File: chrome://calendar/content/calendar.xul
Line: 1

Error: launchBrowser is not defined
Source File: chrome://calendar/content/calendar.js
Line: 450

Seems the file is not getting preprocessed. Caused by Bug 346762 that added applicationUtil.js in a new place.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #270348 - Flags: review?(michael.buettner)
Patch should fix the issue. Sorry for missing the one remaining #ifdef and removing the pre-processing.
Comment on attachment 270348 [details] [diff] [review]
bustage fix, preprocess applicationUtil.js

r=mvl
Attachment #270348 - Flags: review?(michael.buettner) → review+
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7
Duplicate of this bug: 386460
VERIFIED with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070824 Calendar/0.7pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.