Last Comment Bug 38637 - Mozilla should have a Motif-embedding widget
: Mozilla should have a Motif-embedding widget
Status: RESOLVED WONTFIX
: embed, helpwanted
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Other
: P3 normal (vote)
: Future
Assigned To: Judson Valeski
: John Morrison
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-08 21:49 PDT by Daniel Roberts
Modified: 2001-10-15 16:07 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Daniel Roberts 2000-05-08 21:49:17 PDT
Since there is an ActiveX embedding control available for Windows, and a GTK+-
embedding widget available for Linux now, I think it would be really cool if we 
also had a Motif embedding widget for CDE and commercial Unix (e.g., Solaris/HP-
UX) folks.

This may be related to bug 22266.
Comment 1 Roland Mainz 2000-05-09 05:18:17 PDT
Does this include support for anicient and obsolete Motif 1.x, too ? 
Comment 2 Daniel Roberts 2000-05-09 13:05:20 PDT
I think it should, if at all possible.  Motif 1.2 is *NOT* all that obsolete--
most free Unices effectively have only Motif 1.2 available to them, since 
Lesstif (http://www.lesstif.org) is most stable in its Motif 1.2 emulation at 
the moment.  However, my impression is that there are still quite a lot of 
older commercial Unix installations w/ Motif 1.2 out there, also.  So I say, 
let it support Motif 1.2, unless it really isn't feasable.
Comment 3 Roland Mainz 2000-05-09 13:28:51 PDT
If the GTK/Gnome/KDE people make their "rants" about Motif they mainly complain
about the problems in/with Motif 1.2 - if 1.2 would be wiped-out much of those
complaints would disappear.
My first priority would be to focus on 2.1 (CDE itself is 2.1-based and it has -
without vendor mods - limited compatibility to 1.2...), then look how to get-in
compatibility kluges for 1.2.
Making a 1.2-widget which is somewhat 2.1-compatible wouldn't be much fun in the
future...
Comment 4 Peter Trudelle 2000-05-11 18:24:19 PDT
Would be nice, but my team isn't doing it any time soon.  moving to m20, 
putting on helpwanted radar.
Comment 5 Peter Trudelle 2000-05-25 15:23:26 PDT
Mass-moving all M20-M30 XPToolkit bugs to Future
Comment 6 Blake Ross 2000-06-25 01:26:50 PDT
*spam* changing qa contact from nobody@mozilla.org to me (BlakeR1234@aol.com) 
on 121 open or resolved (but not verified) bugs.  sorry for the spam everybody, 
but most of these bugs would just remain dormant and not checked by QA 
otherwise.  I'm not sure how so many bugs have nobody as their QA contact, but 
I suspect this is the fault of some sort of bugzilla corruption that happened 
at some point (most of these bugs are in the 20000-26000 range, and I don't see 
where in the activity log that QA contact explicitly changed to 
nobody@mozilla.org)

Anyways, sorry again for spam.  If you really get annoyed, I'm usually 
available in #mozilla on IRC for torture.
Comment 7 Doug Turner (:dougt) 2000-06-27 13:25:26 PDT
reassigning to jud.
Comment 8 hacker formerly known as seawood@netscape.com 2001-10-15 16:07:36 PDT
The motif port has been removed from the tree.

Note You need to log in before you can comment on or make changes to this bug.