Last Comment Bug 3864 - backspaces/navigation keys handled improperly
: backspaces/navigation keys handled improperly
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: Trunk
: x86 Windows NT
: P1 normal (vote)
: M6
Assigned To: joki (gone)
: Jan Carpenter
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-16 16:09 PST by tague
Modified: 1999-06-15 18:37 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description tague 1999-03-16 16:09:16 PST
The current Seamonkey architecture tries to handle navigation keys as Virtual
Keys (WM_KEYUP/WM_KEYDOWN) messages.  This prevents input methods from ever
seeing backspace events, so Japanese users can't correct their input.  *ALL*
key events, including Navigation events have to be handled after input methods
have a chance at them - this means they have to be handled on the WM_CHAR event
for Windows.
Comment 1 bobj 1999-04-01 17:48:59 PST
Changed from P3 to P1.  We need the keyboard events fixed ASAP because the
Japanese input methods depend upon this.
Comment 2 joki (gone) 1999-04-05 17:45:59 PDT
The WM_CHAR part of this is being fixed.  Tague, still need you to get back to
me on how to handle navigation keys which don't fire a WM_CHAR.
Comment 3 tague 1999-04-05 17:58:59 PDT
Check to see if it is handled by the default window proc - if it is, leave it
alone, otherwise process to your hearts cotnent.
Comment 4 joki (gone) 1999-04-05 18:12:59 PDT
Okay.  Unfortunately processing the event through the default proc *before*
going to the content system is a pretty major change.  We currently handle all
events before default processing.  I'm going to push this to M5 while we think
about this.
Comment 5 bobj 1999-04-07 17:32:59 PDT
Cross reference to related bug:
   http://bugzilla.mozilla.org/show_bug.cgi?id=3546
Comment 6 joki (gone) 1999-04-13 16:09:59 PDT
Sorry, mistakenly closed.
Comment 7 vidur (gone) 1999-04-27 13:24:59 PDT
Moving off M5 radar since Tom is out of town.
Comment 8 tague 1999-06-15 18:37:59 PDT
fixed as part of the big keyboard whackage at least.  marking verified

Note You need to log in before you can comment on or make changes to this bug.