Closed Bug 386415 Opened 13 years ago Closed 8 years ago

No margin-bottom for FORM element in standards mode?

Categories

(Core :: Layout, defect, trivial)

x86
Linux
defect
Not set
trivial

Tracking

()

RESOLVED INVALID

People

(Reporter: tokul, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; lt-LT; rv:1.8.1.4) Gecko/20070508 Iceweasel/2.0.0.4 (Debian-2.0.0.4-0etch1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; lt-LT; rv:1.8.1.4) Gecko/20070508 Iceweasel/2.0.0.4 (Debian-2.0.0.4-0etch1)

In html compliance mode Firefox (Build ID = Iceweasel, but I've also tested "Mozilla/5.0 (X11; U; Linux i686; lt; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4" in -safe-mode) does not render new line after </form> tag. Opera 9.21 adds line.

In quirks mode line is added. Opera 9.21 does not add line.

IE6 and Konqueror 3.5.5 add line in both modes.

Reproducible: Always

Steps to Reproduce:
1. Load sample page in Mozilla and Opera
2. Check grey table row size

Actual Results:  
http://www.topolis.lt/test/form-blues.jpg

Expected Results:  
Some consistency between browsers.
From reading bug 41806 and bug 341891, I can tell that this is an intentional difference between quirks mode and standards mode, but I can't tell why the difference exists.

Perhaps other browsers are incorrectly giving FORM elements a margin.  Have you tried reporting the bug to Opera and Konqueror? :)
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Summary: adds or does not add new line after </form> tag → No margin-bottom for FORM element in standards mode?
My favorite browser first. Others later. Will try contacting Opera and KDE.
Per HTML5, the form element is expected to have no margins in standards mode.
This is now implemented in all major browsers. So this is no bug.

(Only in quirks mode, a margin-bottom: 1em; is expected).
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
(In reply to Daniel.S (mostly offline during the week) from comment #3)
> Per HTML5, the form element is expected to have no margins in standards mode.
> This is now implemented in all major browsers. So this is no bug.
> 
> (Only in quirks mode, a margin-bottom: 1em; is expected).

Test page was not in HTML5 compliance mode. It was in HTML 4.01 Transitional. You can't justify HTML4 compliance based on unfinished HTML5 specification.

Issue is old and I've already solved my problem with css.
(In reply to Tomas from comment #4)
> Test page was not in HTML5 compliance mode. It was in HTML 4.01
> Transitional. You can't justify HTML4 compliance based on unfinished HTML5
> specification.

The page was rendered in Almost Standards Mode (which is the same thing) because the doctype contained a system identifier, see http://hsivonen.iki.fi/doctype/

HTML4 did not specify rendering, so I can't base the decision on HTML4.

While there is no normative definition for rendering HTML documents, HTML5 gives some hints (for example that form has no margins). Browsers have aligned to that hint.
Some parts of HTML5 are quite stable, so it's reasonable to refer to them :)

Sorry for not explaining the cause in more detail.

> Issue is old and I've already solved my problem with css.

I didn't mean to concern you. I have closed the report because it did not report an actual bug but expected bahaviour. Simple clean up.

Have a nice day.
You need to log in before you can comment on or make changes to this bug.