Last Comment Bug 386437 - Use inline tree editing instead of a modal dialog when changing keywords in the Search Engines Manager
: Use inline tree editing instead of a modal dialog when changing keywords in t...
Status: RESOLVED FIXED
: polish
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: Trunk
: All All
: -- enhancement with 3 votes (vote)
: Firefox 34
Assigned To: Ryan Flint [:rflint] (ping via IRC for reviews)
:
Mentors:
Depends on: 1106559
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-30 09:47 PDT by Adam Kowalczyk
Modified: 2014-12-23 12:46 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Adam Kowalczyk 2007-06-30 09:47:45 PDT
Right now when the user clicks the "Edit Keyword" button, a dialog pops up allowing to enter the keyword.

Modal dialogs should be avoided when possible and there's certainly a better and more elegant alternative in this case. When the user clicks "Edit Keyword", the appropriate treecell should be focused and made editable, taking advantage of bug 201499.
Comment 1 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-06-30 15:05:41 PDT
My original implementation used editable treecells, but I switched over to the prompt due to accessibility concerns. Currently you can't invoke edit mode directly without a mouse (bug 350346) and they aren't read (by JAWS at least) when using a button to fiddle with startEditing(). I'll look into getting this to work properly.
Comment 2 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-06-30 15:08:09 PDT
*sigh*
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2014-12-23 12:45:15 PST
Fixed by bug 1106559 (via bug 1106205).
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2014-12-23 12:46:02 PST
*** Bug 640418 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.