Javascript is not disabled when designMode is on

RESOLVED FIXED in mozilla1.9alpha8

Status

()

defect
RESOLVED FIXED
12 years ago
6 years ago

People

(Reporter: martijn.martijn, Assigned: peterv)

Tracking

({regression, testcase})

Trunk
mozilla1.9alpha8
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
Posted file testcase (obsolete) —
See testcase, you should not get an alert after 500ms, and clicking on the button should not give an alert.
This regressed with bug 237964, I think.
(Assignee)

Updated

12 years ago
Assignee: nobody → peterv
(Assignee)

Comment 1

12 years ago
Posted patch v1Splinter Review
Doh.
Attachment #270614 - Flags: superreview?(jst)
Attachment #270614 - Flags: review?(jst)
Attachment #270614 - Flags: superreview?(jst)
Attachment #270614 - Flags: superreview+
Attachment #270614 - Flags: review?(jst)
Attachment #270614 - Flags: review+

Comment 2

12 years ago
Definitely need to Mochitest version of this testcase.
Flags: in-testsuite?
(Assignee)

Comment 3

12 years ago
Posted patch MochitestSplinter Review
Attachment #270491 - Attachment is obsolete: true
Attachment #270741 - Flags: review?(martijn.martijn)
(Assignee)

Comment 4

12 years ago
Fixed, but still need to checkin the Mochitest (waiting for Martijn's review).
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

12 years ago
Comment on attachment 270741 [details] [diff] [review]
Mochitest

Oops, sorry for the delay.

The test looks fine to me, but why are you using such large delay values, 500 and 1000?
I just tested with 50 and 100 and that seems to work just fine.
Attachment #270741 - Flags: review?(martijn.martijn) → review+
(Assignee)

Updated

12 years ago
Flags: in-testsuite? → in-testsuite+
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → mozilla1.9beta1
Martijn: We *think* this test is causing us problems in bug#517130. Can you have a look? If yes, should we keep that separate bug, or just reopen this bug?
(Reporter)

Comment 7

10 years ago
I don't know why the test is causing problems on Fennec. Afaict, it shouldn't, because the test seems sound to me.

Comment 8

6 years ago
It seems this wasn't fixed completely.  I filed bug 822213.
You need to log in before you can comment on or make changes to this bug.