Firefox always warns "Software Update Failed" when running from non-admin account

RESOLVED DUPLICATE of bug 383518

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 383518
11 years ago
11 years ago

People

(Reporter: Trogdor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

I updated Firefox to 2.0.0.4.  When I run Firefox from my administrator account (which as a rule I try not to use), it runs normally, but when I run it from an account without admin rights, I always get a warning:  

Software Update Failed
One or more files could not be updated.  Please make sure all other applications are closed and that you have permission to modify files, and then restart Firefox to try again.



Reproducible: Always

Steps to Reproduce:
1.  Log in to my machine with an account without admin rights.
2.  Launch Firefox.

Actual Results:  
See "Details" above

Expected Results:  
I would expect no error dialog, or possibly a very detailed list of what files aren't being updated

Windows 2000, updated to the latest stuff via Windows Update; non-admin-rights account; my boot drive is F:; a secondary drive is C:
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383518
You need to log in before you can comment on or make changes to this bug.