Closed Bug 386731 Opened 13 years ago Closed 13 years ago

After a session restore, a contenteditable element cant be changed through js

Categories

(Core :: DOM: Editor, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: albert.brand, Unassigned)

References

()

Details

(Keywords: testcase)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007070304 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007070304 Minefield/3.0a7pre

See the testcase URL (from bug #237964). Open the URL, and with session restore turned on, reload the browser. Press the readonly button, and try to edit the text in the contenteditable region. This is still possible.

Reproducible: Always



Expected Results:  
After a session restore, the contenteditable logic should still work the same: turned off, the text shouldn't be editable.
Component: General → Editor
Product: Firefox → Core
Version: unspecified → Trunk
Keywords: testcase
QA Contact: general → editor
Can't reproduce anymore in todays build, good work Peter. Resolving as fixed.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007070604 Minefield/3.0a7pre ID:2007070604
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
I'm assuming that this was fixed by a patch that was checked into 237964?  (That's the only bug / code that's referred to in any way here.)  Otherwise, if you don't know, it should be re-resolved as WORKSFORME.
You need to log in before you can comment on or make changes to this bug.