ICS Cals dont update after upgrade from 0.31 to 0.5

VERIFIED DUPLICATE of bug 387559

Status

defect
--
critical
VERIFIED DUPLICATE of bug 387559
12 years ago
12 years ago

People

(Reporter: fhebeler, Unassigned)

Tracking

({dataloss})

Sunbird 0.5
x86
Windows XP

Details

(Whiteboard: [0.5 disappearing events])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 0.5

I just updated sunbird (tried lightning, too) from 0.31 to 0.5 and I found I couldnt use my remote calendar files anymore. They are in a WebDAV dir on a Apache 2.2. (unix) server with mod_dav. GET and PUT commands reach the server. When ics file is subscribed to first, events show fine, but new entries are not written to remote file and after calendar reload, no events are shown at all.
Events from local calendar are not shown either, unless all remote ics calendars are deleted from sunbird calendar list.
same with lightning.
did a clean install (deleted all sunbird folders with prefs, etc), didnt help.
reinstalled 0.31: worked a treat.
Deleted all folders again (and did regclean), installed 0.5, no good.
Copied remote ics to local disc and imported it to local calendar: all events show. Exported to ics from this local calendar and put it online on the remote server: same problem as before, so I guess it shouldnt be a format problem...

Switched back to 0.31 now until i get a clue what the reason might be.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to calendar on the network
2. Create new event
3. Reload
Actual Results:  
After reload (manual or automatic) all events disappear (sometimes only events of some calendars at first, after 2nd reload all are gone).
New events are not written to remote calendar.


Expected Results:  
Events in calendars should show, including the new events.
New events should be written to remote ics file.

Downloaded theme, but did not use it. Did a clean install without themes after this.
Tried lightning for thunderbird, but the problem was the same. 
couple of themes and add-ons for thunderbird of course, including syncml plugin, etc.
Keywords: dataloss
Version: unspecified → Sunbird 0.5
Oh, if I wait really long (leave sunbird idling), I get an error message:

There has been an error reading data for calendar: Public. It has been
placed in read-only mode, since changes to this calendar will likely
result in data-loss.  You may change this setting by choosing 'Edit
Calendar'.

Error number: ICS_NO_ERROR
Description: [Exception... "Component returned failure code:
0x804a0100 [calIICSService.parseICS]"  nsresult: "0x804a0100
(<unknown>)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/js/calIcsParser.js
:: ip_parseString :: line 60"  data: no] 
Might be related to bug 380291
-----
I have checked that GET, HEAD, OPTIONS and PROPFIND are not limited in the DAV sevtion of the http.conf 
We have seen in other circumstances, that this is due to the use of a proxy on the network.  Felix, are you using a proxy on your network?
Whiteboard: [0.5 disappearing events]
No, although I have some network issues on the university computers I use, I can repeat this problem on three different computers, two of which are connected to the internet via a cable modem / router, so I guess it's to do with my webdav server / sunbird 0.5 configuration rather than the network.
So no, on the machine itself, there is no proxy configured.
According to the bug description I think this is a duplicate of Bug 387559. 
Is your server configured to require authentication for PUT but not for GET?
Felix, could you provide the requested information?
Sorry, I was away for a while.
As I wrote above I dont limit just PUT, at least I think, plz check the http.conf section yourself:

DAVLockDB /scratch/7/wwwserv/apache/var/DAVLock
<Directory "/scratch/7/wwwserv/apache/htdocs/calendar">
	Options Indexes
	Order deny,allow
	AllowOverride AuthConfig
	DAV On
	AuthType Basic
	AuthName "By Invitation Only"
	AuthUserFile /scratch/7/fhebeler/wwwserv/apache/conf/passwd
	<LimitExcept HEAD OPTIONS PROPFIND>
        require user webdav
   	</LimitExcept>
</Directory>
Uhm. Sorry. I did not mention this above, i just notice. And I also noticed I might have mixed up the webdav except with other directory entries on the server.
Could you please tell me what do put into the LimitExcept section? I'll try and install sunbird 0.7 again and test it with any changes i made.
Cheers
Felix
I'm having the same exact problem. Sunbird 0.3x worked fine, but with 0.5 and 0.7 (9-10-07 nightly build), I can't post new items to the calendar on WebDAV. I am not using a proxy. I have tried various LimitExcept clauses...The release notes state that this should work:

<LimitExcept GET HEAD OPTIONS PROPFIND>

But it doesn't. I've also tried this:

<LimitExcept GET HEAD OPTIONS POST PROPFIND>

and this:

<LimitExcept GET HEAD POST PROPFIND>

To no avail. If I remove the LimitExcept clause entirely, and Require valid-user for everything, I can make it work, but then it's not possible to subscribe to the .ics as read-only without knowing the password, which is a necessity.

I forgot to mention in my previous comment, I get this error in the SunBird error console:

Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.requestSucceeded]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///C:/Program%20Files/Calendar/components/calICSCalendar.js :: anonymous :: line 385"  data: no]
Source File: file:///C:/Program%20Files/Calendar/components/calICSCalendar.js
Line: 385
Sorry to make these comments one at a time...I keep thinking of more to add. To me, it seems like this bug is being caused by Sunbird assuming that, since it didn't need a password to read the .ics file, it won't need a password to write it. If it doesn't need a password to read or write it seems to be fine, and if it does need a password to read and write, it's also fine. It's when authentication is needed to write, but not to read, that there's a problem.

Thanks,
Tom
(In reply to comment #9)
Tom, you are seeing Bug 387559 that was resolved fixed today. I'd like you to retest with tomorrows Sunbird 0.7pre nightly build (20070912) if it works.
Stefan,

Okay, I'll give it a try tomorrow.

Thanks,
Tom
Ok, I tried the nightly 0.7pre release with my setup described above, same problem. I can view events, I can create new events, but they are not written to the remote ics and all events disappear once I need to refresh the cals.
Sorry, forgot the revision: rv:1.8.1.7pre
Felix, the nightly build containing the fix from Bug 387559 is not yet available, see Comment #12.
O_o. Sorry. I wonder if I contribute here or just make things more complicated and produce a lot of spam for lots of people... Anyway. I mean good! Haha.
Tested sunbird and lightning 0.7pre nightlies  now and they seem to work a treat!
Nice integration for lightning, great work! Now if only the SyncML sync would work well...
Seems to be fixed in today's build. Thanks!

Tom
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387559
I think this is the problem I have also. I tried to sync my calendar through FTP, and now each time I open Sunbird, I get this error message: http://img151.imageshack.us/img151/8992/calzx5.png - It says the calendar is read-only to prevent file corruption.

I use WinXP with Sunbird 0.5

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070614 Sunbird/0.5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.