If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when visiting blogs.wsj.com [@ gfxSkipCharsIterator::SetOffsets]

RESOLVED DUPLICATE of bug 386584

Status

()

Core
Layout: Text
--
critical
RESOLVED DUPLICATE of bug 386584
10 years ago
6 years ago

People

(Reporter: Franklin Bynum, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070304 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070304 Minefield/3.0a7pre

Everytime I go to the address listed, the browser crashes.  Other posts on the website do not cause a crash, nor does the main page.  Just the post linked above, so far.

Reproducible: Always

Steps to Reproduce:
1. Go to http://blogs.wsj.com/law/2007/05/30/a-font-of-new-supreme-court-rules/
2. Crash
Actual Results:  
Crash

Expected Results:  
Page load

https://crash-reports.mozilla.com/reports/report/index/105b83dc-29a0-11dc-9282-001a4bd46e84?date=2007-07-03-20
https://crash-reports.mozilla.com/reports/report/index/4b5893d9-29a0-11dc-aa8b-001a4bd43ed6?date=2007-07-03-20
https://crash-reports.mozilla.com/reports/report/index/01a3253d-29a0-11dc-8ccc-001a4bd43ed6?date=2007-07-03-20

Breakpad crash report server seems to be down, but I'm assuming those reports made it there even though I can't see them via the web interface.
No crash here with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070308 Minefield/3.0a7pre and a new profile.
Keywords: crash
Finally I could reproduce it once, with my default profile.

Comment 3

10 years ago
The Breakpad server is up, it's just changed to crash-stats.mozilla.com. http://crash-stats.mozilla.com/report/index/105b83dc-29a0-11dc-9282-001a4bd46e84

0  	gfxSkipCharsIterator::SetOffsets(unsigned int,int)
1 	BuildTextRunsScanner::SetupBreakSinksForTextRun(gfxTextRun *,int,int)
2 	BuildTextRunsScanner::BuildTextRunForFrames(void *)
3 	BuildTextRunsScanner::FlushFrames(int)
4 	BuildTextRuns
5 	nsTextFrame::EnsureTextRun(nsIRenderingContext *,nsIFrame *,nsLineList_iterator const *,unsigned int *)
6 	nsTextFrame::Reflow(nsPresContext *,nsHTMLReflowMetrics &,nsHTMLReflowState const &,unsigned int &)
7 	nsLineLayout::ReflowFrame(nsIFrame *,unsigned int &,nsHTMLReflowMetrics *,int &)
8 	nsBlockFrame::ReflowInlineFrame(nsBlockReflowState &,nsLineLayout &,nsLineList_iterator,nsIFrame *,LineReflowStatus *)
9 	nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState &,nsLineLayout &,nsLineList_iterator,int *,LineReflowStatus *,int)
Component: General → Layout: Fonts and Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: unspecified → Trunk

Comment 4

10 years ago
This is essentially the same crash as in bug 386584.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Summary: Crash when visiting blogs.wsj.com → Crash when visiting blogs.wsj.com [@ gfxSkipCharsIterator::SetOffsets]
Duplicate of bug: 386584
(Assignee)

Updated

6 years ago
Crash Signature: [@ gfxSkipCharsIterator::SetOffsets]
You need to log in before you can comment on or make changes to this bug.