Closed Bug 386920 Opened 13 years ago Closed 13 years ago

Text with "font-variant: small-caps" no longer wraps properly

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mlemieu, Assigned: roc)

References

()

Details

(Keywords: regression, testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/2007070404 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/2007070404 Minefield/3.0a7pre

Text is not wrapping properly inside its div and instead extends on a single line.

Reproducible: Always

Steps to Reproduce:
1. Open current nightly in Minefield
2. Navigate to http://xkcd.com
3. Observe that text doesn't not wrap properly
Actual Results:  
Text appears as single line.

Expected Results:  
Text wraps inside div as previously.
Confirmations from various Win platforms here:
http://forums.mozillazine.org/viewtopic.php?p=2953161#2953161
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
It is due to the use of 'font-variant:small-caps'.
Attached file minimal testcase
That regressed between 2007070320 and 2007070321 (Mac Builds)
--> bug 385423
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Flags: blocking1.9?
Assignee: nobody → roc
Keywords: testcase
Summary: Layout Regression @ xkcd.com → Text with "font-variant: small-caps" no longer wraps properly
Slight clarification and simplification: just put 

<span style="font-variant: small-caps">a</span>

in a paragraph and it stops wrapping from the small caps *onwards* for the rest of the paragraph.
Attached patch fixSplinter Review
The glyph-copying process is wiping out the line-break data, which is not really a good idea. This doesn't usually matter because we're usually copying into new textruns, but the small-caps code copies glyphs into an existing textrun and expects the line-break data to be preserved.
Attachment #271174 - Flags: review?(vladimir)
Flags: blocking1.9? → blocking1.9+
Attachment #271174 - Flags: review?(vladimir) → review+
Flags: in-testsuite?
Checked in.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Checked in reftest.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.