Closed Bug 387074 Opened 14 years ago Closed 14 years ago

Links stop working after using the back button

Categories

(Core :: DOM: Navigation, defect)

x86
Windows Vista
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 364461

People

(Reporter: leaf.of.grass, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007070522 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007070522 Minefield/3.0a7pre

After some period of browsing, links stop working. So far I can not reproduce this everywhere, but on links that are attached to graphics it is very common. Seems to have regressed recently, as I am using an hourly build and visit the link provided semi regularly.

Reproducible: Always

Steps to Reproduce:
1. visit provided url
2. click any of the graphics that link to another page
3. press back button or alt+left arrow
4. try clicking some of the other shield graphics, or even the same one
5. usually at this point the links don't work anylonger. if not, keep repeating, eventually they will no longer forward you to the linked page
Actual Results:  
Links stop working.

Expected Results:  
Links should always work

Reloading the page fixes the problem, also right-clicking "open link..." works
Apologies, it appears I may have filed a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=386276
Probably. Regression on 14 June 2007; points to bug 371360, which depends on bug 364461.
Component: General → History: Session
Product: Firefox → Core
QA Contact: general → history.session
Confirmed on XPSP2 as well
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9?
Keywords: regression
Version: unspecified → Trunk
Yep.  This is the same issue as bug 386276, etc.  Not sure why it didn't just get marked that way...
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: blocking1.9?
Resolution: --- → DUPLICATE
Duplicate of bug: 364461
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.