Status

()

defect
--
major
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: bugmozz, Assigned: mrbkap)

Tracking

({regression, verified1.8.1.13})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +
blocking1.8.1.13 +
wanted1.8.1.x +
blocking1.8.0.next +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression from bug 384750)

Attachments

(1 attachment)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070513 Minefield/3.0a7pre ID:2007070513

[renge]
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1183665120&maxdate=1183666019

[error console]
Error: uncaught exception: [Exception... "Could not convert JavaScript argument arg 1 [nsIStringBundle.formatStringFromName]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: XStringBundle :: getFormattedString :: line 33"  data: no]
-> bug 384750
can't set this block 384750 because it's a [sg] bug
Severity: normal → major
Component: Preferences → Page Info
Flags: blocking-firefox3?
Assignee: nobody → mrbkap
Blocks: 384750
Posted patch Proposed fixSplinter Review
With this patch, we can back out the fix for bug 387053 -- apparently, there are lots of places where we pass XPCNativeWrappers into code that wouldn't normally get them. In this case, we are in an XBL binding, whose filename is "XStringBundle". This hopefully won't hurt performance too much, since most implicit XPCNativeWrappers' uses should be in the files that we created them for.
Attachment #271192 - Flags: superreview?(jst)
Attachment #271192 - Flags: review?(jst)
QA Contact: preferences → page.info
Duplicate of this bug: 387129
Attachment #271192 - Flags: superreview?(jst)
Attachment #271192 - Flags: superreview+
Attachment #271192 - Flags: review?(jst)
Attachment #271192 - Flags: review+
Fix checked into trunk.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070618 Minefield/3.0a7pre ID:2007070618

VERIFIED
Status: RESOLVED → VERIFIED
Flags: blocking-firefox3? → blocking-firefox3+
Flags: blocking1.8.1.9+
Whiteboard: regression from bug 384750
Flags: wanted1.8.1.x+
Not taking bug 384750 in 1.8.1.12, don't need it's regression fix
Flags: blocking1.8.1.12+ → blocking1.8.1.13+
Comment on attachment 271192 [details] [diff] [review]
Proposed fix

This patch applies as-is.
Attachment #271192 - Flags: approval1.8.1.13?
Comment on attachment 271192 [details] [diff] [review]
Proposed fix

approved for 1.8.1.13, a=dveditz for release-drivers
Attachment #271192 - Flags: approval1.8.1.13? → approval1.8.1.13+
Fixed on the 1.8 branch.
Keywords: fixed1.8.1.13
verified fixed for the 1.8 branch with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13 ID:2008031114
Flags: blocking1.8.0.15+
Comment on attachment 271192 [details] [diff] [review]
Proposed fix

taking into distro patches.
Attachment #271192 - Flags: approval1.8.0.15?
You need to log in before you can comment on or make changes to this bug.