[FIX]Tables with scrollable rowgroups take up too much space

RESOLVED FIXED

Status

()

Core
Layout: Tables
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

Trunk
x86
Linux
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

This is a regression from bug 367706.  Basically, the change to nsTableFrame::CalcDesiredHeight was wrong.

Patch and tests coming up.
Flags: blocking1.9?
Created attachment 271471 [details] [diff] [review]
Fix
Attachment #271471 - Flags: superreview?(roc)
Attachment #271471 - Flags: review?(bernd_mozilla)

Comment 2

11 years ago
I think the reftest will fail due to the scrollbar thumb size depending on the amount of scrollable content.
Oh, hmmm.....  Both thumbs are the minimal size here.  But I'll toss "visibility: hidden" on both tables to make sure that's not a problem.

Updated

11 years ago
Attachment #271471 - Flags: review?(bernd_mozilla) → review+
Attachment #271471 - Flags: superreview?(roc) → superreview+
Checked in, with test.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9? → in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.