First click on Bookmarks menu pops Add Bookmark dialog

RESOLVED WORKSFORME

Status

()

Core
Disability Access APIs
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Ginn Chen, Assigned: Ginn Chen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

11 years ago
1) Start firefox
2) Click Bookmarks menu, wait a while
3) "Add Bookmark" dialog pops
4) Close it, click Bookmarks menu again, Bookmarks menu drops as expected
Which build are you testing?
(Assignee)

Comment 2

11 years ago
reproduced on linux nightly build, and my own debug build

I turned on desktop a11y feature, I'm not sure if it matters.
(Assignee)

Comment 3

11 years ago
could not reproduce on another machine

I'll double check tomorrow.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

11 years ago
It's still reproducible on a certain machine with A11y on.
I'll track it.
Status: RESOLVED → REOPENED
Component: Bookmarks → Disability Access APIs
Product: Firefox → Core
Resolution: WORKSFORME → ---
Assignee: nobody → aaronleventhal
Status: REOPENED → NEW
QA Contact: bookmarks → accessibility-apis
(Assignee)

Comment 5

11 years ago
not only bookmarks menu
sometime if I click File menu, I got "New Window".
Assignee: aaronleventhal → ginn.chen
(Assignee)

Comment 6

10 years ago
not reproducible on latest trunk on same machine
Status: NEW → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

10 years ago
it happens again after I added some printf in code
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 8

10 years ago
I can't reliable reproduce this, but I believe it's still there.

From the stack, the call to nsXULPopupManager::ExecuteMenu is from button_release_event_cb in nsWindow.cpp.
But I'm sure I didn't move mouse before releasing the button.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 ID:2008070208

There's another bug out there about this that I commented on, can't find it ATM :(, but this is 100% reproducible for me in safe mode, although in my experience the Add Bookmark Dialog appears... I found though that there's a lot that contributes to reproducing this reliably, if I disable the flash plugin for instance, it seems to lower the frequency, and if I reset the bookmarks to default it goes away. I'm willing to help in any way as this is extremely annoying for me. (btw on a separate debug build I hit an assertion on the first click of any of the menus, might be related...)

I'm on Vista here so I guess OS-->All.
Well, after further looking into this I found that it was my AV (Kaspersky 2009) causing all the trouble for me, it made the assertions and consequently this behavior... this is probably the wrong bug to report this in anyhow, can anyone direct me to the equivalent of this bug on Windows? thanks
(btw I had to completely uninstall the AV, i.e. exiting or pausing the program was of no use).
(In reply to comment #10)
> Well, after further looking into this I found that it was my AV (Kaspersky
> 2009) causing all the trouble for me, it made the assertions and consequently
> this behavior... this is probably the wrong bug to report this in anyhow, can
> anyone direct me to the equivalent of this bug on Windows? thanks
> (btw I had to completely uninstall the AV, i.e. exiting or pausing the program
> was of no use).

Are you talking about #406646 ?

I'm having the same issue BTW. And it could not reliably reproduced, unfortunately.
Duplicate of this bug: 466320
Duplicate of this bug: 470812

Comment 14

9 years ago
I can confirm this behavior daily on my machine. I'm running a laptop with Windows Vista Home Premium SP1. It seems to get worse when on Power Saver mode versus High Performance Mode. Power Saver in Vista reduces CPU clock speed to save battery life. 

As far as I can tell, the problem is with the time between mouse button down and mouse button up action. If you press the mouse down and up really fast, you get a bookmark this page dialog box. If you hold down the mouse button for some time then raise the mouse button, you don't get the dialog. The problem also seems to happen on first run of FF after a boot or a wake from sleep. It doesn't happen on subsequent runs of FF. I've been using FF on this machine for the past 3 months, updating versions as I go, and it is evident on all the builds I used, including 3.0.6.

In order to test this, feed the Bookmarks menu item programatically with a very short mouse down and up action, and see what happens. I suspect with a very short mouse down/up action, like 1ms, you will see this. Also, make sure that this is first FF run after boot, and FF is not cached in computer memory. Testing on a slower machine (<1Ghz) or a machine on Power Saver mode (reduced clock rate) might also yield positive results.

Comment 15

7 years ago
Fernando, can you look at this?

Comment 16

7 years ago
I cannot reproduce this one

Comment 17

7 years ago
close as worksforme per comment #16, please reopen if you can reproduce it on fx4.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.