Tables in an iframe generated with src="javascript:void(0)" are rendered in quirks mode

RESOLVED DUPLICATE of bug 450191

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 450191
11 years ago
9 years ago

People

(Reporter: Alfonso Martinez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 271988 [details]
Testcase to show the problem

The test case shows that if a document is generated on an iframe that had src="javascript:void(0)" then the font size of the text in the table doesn't inherit like it should in standards mode.

The document.compatMode as seen in Firebug seems to point that the document is in CSS1Compat

Tested in windows and Mac, with 2.0.0.4 and Gran Paradiso 3 alpha6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 450191
You need to log in before you can comment on or make changes to this bug.