Page load hangs when javascript funtion is called

RESOLVED DUPLICATE of bug 81980

Status

()

defect
RESOLVED DUPLICATE of bug 81980
12 years ago
12 years ago

People

(Reporter: belko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

The browser never stops loading the page after calling a javascript function. It appears as if it's stuck in a loop.  I have to press the stop button.  This did not happen in previous versions of Firefox.


Reproducible: Always

Steps to Reproduce:
1. Create an html file from the following code
<html>
<head>
<script>
function hello() {
document.write("Hello World!");
return;
} 
</script>
</head>

<body>
 
<form id="form1">
Enter Value<input type="text" id="red" size="10" >
<input type="button" onclick="javascript:{hello()}" value="Go">
</form>

</body>
</html>


2. bring up the page in the browser, press the Go button.  
Actual Results:  
Page load never completes.

Expected Results:  
It should finish loading the page

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 81980
You need to log in before you can comment on or make changes to this bug.