Hebrew displayed incorrectly when interspersed with English

RESOLVED DUPLICATE of bug 60546

Status

()

defect
RESOLVED DUPLICATE of bug 60546
12 years ago
12 years ago

People

(Reporter: servalan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

In some instances Hebrew doesn't display correctly when interspersed with English. The Hebrew characters are displayed too wide & override the text. There is an attached screenshot & a HTML example in the URL.

The example displays perfectly in IE7.

Reproducible: Always

Steps to Reproduce:
1. Open example URL in browser.
Actual Results:  
The resulting page looks wonky, like the attached screen shot. The Hebrew is rendered too wide & overwrites the English characters.

Expected Results:  
The resulting page should display the Hebrew characters as depicted in the IE7 screen shot attached.

Apologies for this bug report - I expect it is a known problem, but I cannot find any existing bugs in the bugzilla database which describe this problem. The folks in the firefox IRC channel suggested I just log a bug.
(Reporter)

Comment 1

12 years ago
(Reporter)

Comment 2

12 years ago
Cannot reproduce, i can see the correct chars (based on screenshots)
Works for me on Branch and Trunk

Could you check how is setup your View menu / Charset? 
check that it is on Unicode (UTF-8)

if this solves the problem please mark this bug as Resolved Invalid
(Reporter)

Comment 4

12 years ago
Works for me...

Could you try in Safe mode?
http://kb.mozillazine.org/Safe_Mode
(Reporter)

Comment 6

12 years ago
The example HTML is part of a much larger text which is in progress. You can
view the draft text here:
http://www.ebookforge.net/pourlean/sah-h.html#V2-167

if needed. The text contains Arabic, Greek & Hebrew unicode characters. The
Arabic & Greek are displayed without hassles. Most of the Hebrew is also fine.
I reduced the HTML down to this one instance for the example thinking it would
help debug the problem. Maybe the larger file is more help?

I see the problem if I load the example straight from disk. i.e.
file:///D:/boog.html
or remotely off the http server. 2 other volunteers report seeing the problem, 2 others not. It's a mystery so far as to the cause.

Thanks & apologies if this is a non-bug.
(Reporter)

Comment 7

12 years ago
Problem still evident in safe mode - let me know if you need a screen shot.
This seems like a dupe of bug 60546, which is fixed on trunk builds. Does the problem disappear if you check "No Style" under View | Page Style?
(Reporter)

Comment 9

12 years ago
Yes the problem disappears view 'No Style' - thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 60546
You need to log in before you can comment on or make changes to this bug.