Created attachment 272192 [details]
It returns an array in case it was used more than once, but sqlite magically takes care of that for us. It should be renamed to getParameterIndex and return an int.
Attached is a testcase demonstrating that sqlite does in fact handle this gracefully.
Created attachment 272284 [details] [diff] [review]
On the right bug too :)
Comment on attachment 272284 [details] [diff] [review]
Checking in storage/public/mozIStorageStatement.idl;
new revision: 1.7; previous revision: 1.6
Checking in storage/src/mozStorageStatement.cpp;
new revision: 1.23; previous revision: 1.22
Checking in storage/test/unit/test_storage_statement.js;
new revision: 1.3; previous revision: 1.2