Saved Form entrys not deleted via "clear private Data"

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 46845
10 years ago
10 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.5) Gecko/2007071216 Firefox/2.0.0.5

STR: 
- Go to http://www.mozilla.org/wallet/samples/sample2.html
- check the tools -> options -> privacy -> remember what i have entered in forms ... checkbox
- Enter some data into the Form
- Clear Private Data "Saved Form Information"
- Check the sample page again
- the stored form information are not deleted
Keywords: privacy
Can we get a regression range for this?
Flags: blocking1.8.1.6?
Flags: blocking1.8.1.5?
Keywords: regression
Is it just form data, or other sanitization as well?
This WFM: form history is cleared in today's 2.0.0.5 build. Form data on the current page, maybe not. Form history is seen in autocomplete or by hitting down-arrow in a form field.
Flags: blocking1.8.1.6?
Flags: blocking1.8.1.5?
Gavin notes in IRC: see bug 46845 and bug 294258

Is that what you're seeing?
Keywords: privacy, regression
(Reporter)

Comment 5

10 years ago
yes i think its a dupe of bug 46845, thx
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 46845

Comment 6

10 years ago
WFM as well.  Tested with 2004 and 2005rc1 with the same results:

1. Make sure "Remember what I have entered..." is checked
2. Fill out form and submit (fields should clear on submit)
3. Clear private data
4. Down arrow or autocomplete don't show anything (form history is no longer
available)

If you reenter the form data after step #2 above using autocomplete and then
clear the private data in #3, the form data will still be there if you do a
normal refresh (click the button), but a shift+refresh will clear the form data
(which is not related to the form history bug reported here).

Comment 7

10 years ago
hmmm going back to the bad profile and trying again, is WFM. 
You need to log in before you can comment on or make changes to this bug.