bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Places View for Menus broken since bug #337855

RESOLVED FIXED in Firefox 3 alpha7

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: Ronny Perinke, Assigned: mano)

Tracking

({regression})

Trunk
Firefox 3 alpha7
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4pre) Gecko/20070615 Firefox/2.0.0.5pre (Sephiroth/SSE2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4pre) Gecko/20070615 Firefox/2.0.0.5pre (Sephiroth/SSE2)

Uncaught exception, when a submenu of a places-generated menu should open.

Error: uncaught exception: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)" 
location: "JS frame :: chrome://browser/content/places/menu.xml :: onPopupShowing :: line 49"  data: no]

Reproducible: Always

Steps to Reproduce:
1. download the attached rar file and extract it in your firefox directory, it contains a manifest and a xul file (before that, close firefox)

2. start firefox and enter "chrome://bugXXXXXX/content/" (replace XXXXXX by the number of this bug)
3. try out the 3 history menus, where only the third (no grouping) will work
Actual Results:  
exception and the submenus of the first two history menus won't open

Expected Results:  
no exception and submenus opens

broken since 16.06.2007
(Reporter)

Comment 1

11 years ago
Created attachment 272309 [details]
testcase
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Keywords: regression
Version: unspecified → Trunk
Places bugs in that range are bug 337855 and bug 384515.
Created attachment 272338 [details] [diff] [review]
patch

We don't 'officially' support query sub menu yet though (this is all broken on mac, for example)
Assignee: nobody → mano
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #272338 - Flags: review?(dietrich)
Attachment #272338 - Flags: review?(dietrich) → review+

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+

Updated

11 years ago
Target Milestone: --- → Firefox 3 M7
mozilla/browser/components/places/content/menu.xml 1.82
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 5

11 years ago
verified with: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072505 Minefield/3.0a7pre

can we get a unit test for this one? or not applicable since it's unsupported.
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
(Reporter)

Comment 6

11 years ago
broken again with the hourly build from 19-11-2007 18:12
last working build is the one from 17:22 

checkins http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=1195521720&maxdate=1195524719&cvsroot=%2Fcvsroot

so it's probably caused by bug 387746
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
File a new bug.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
removing ancient in-testsuite requests
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.