Outgoing SMTP always fails in latest SeaMonkey builds.

RESOLVED INVALID

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Jason Bassford, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Vista
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
As of the 0701 build everything worked just fine for me.  Around 0707 (I don't recall the exact date) I was no longer able to connect to my SMTP server via Mail.  I just tried again with a 0713 build and the same thing is happening.

When attempting to send mail, I get a error box, saying that it is unable to authenticate to my server.  "The server does not support any compatible insecure mechanism".  This is how I've always had things configured.  My workstation and server are on the same local, private, LAN interface, so I haven't set authentication between those two hosts.

(If I switch to a secure method, I get a similar message complaining about how my server doesn't support a compatible secure authentication mechanism.)

I will attach screenshots of these messages to the bug.  Currently, I'm back at the 0701 build so that I can work with mail.  But, since this isn't something that's I've noticed reported yet, I thought I'd better do so.
(Reporter)

Comment 1

11 years ago
Created attachment 272312 [details]
When sending with insecure authentication.
(Reporter)

Comment 2

11 years ago
Created attachment 272313 [details]
When sending with secure authentication.
(Reporter)

Updated

11 years ago
Keywords: regression

Comment 3

11 years ago
Possibly has something to do with Bug 311657. Can you attach a SMTP protocol log as described under http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#smtp?

Comment 4

11 years ago
Hmm, that's working for me with a custom debug build [Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a7pre) Gecko/200707142020] (GMT), so it's not a general problem. 
A SMTP log would be really useful. If the log doesn't already contain it, the capabilities of the server are of interest.
telnet to your smtp server (usually something like     telnet smptname 25    ) and enter "EHLO" (+enter). This will give a list like this:
250-mail.ruhr-uni-bochum.de NO UCE C=DE
250-STARTTLS
250-AUTH LOGIN PLAIN
250-PIPELINING
250 8BITMIME
(Reporter)

Comment 5

11 years ago
Hmm.  Following those instructions for logging, I got a log file - but it was empty.  There isn't anything unique to SeaMonkey that would invalidate those instructions is there? (Obviously, I put in the correct executable name.)

BTW: I now have both builds of SeaMonkey in my Program Files directory so that I can easily switch back and forth by renaming them whenever I need to do further testing.

As for the capabilities of my server:

220 virgil.dante.com ESMTP Postfix
ehlo virgil.dante.com
250-virgil.dante.com
250-SIZE 10240000
250-VRFY
250-ETRN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
(Reporter)

Comment 6

11 years ago
I guess I should try downloading different nightly builds to determine the exact build that broke this for me...
(Reporter)

Comment 7

11 years ago
Okay, I've narrowed down the regression range:

0705 - SMTP works.
0706 - SMTP fails.
(Reporter)

Comment 8

11 years ago
Looking back, bug 311657 was checked in, and would have taken affect, in the 0706 builds - so that could very well be the problem.
Depends on: 311657
(Reporter)

Comment 9

11 years ago
After reading through the comments in bug 311657, I've solved the problem.  It turned out that I had checked "use username and password" in my SMTP settings - even though I'd specified no authentication mechanism.  Once I removed that, everything worked fine.  (See bug 311657 comment 28.)

I'm resolving this as INVALID, since the behaviour is as expected and this isn't a bug.  Thanks everybody for pointing me in the right direction.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
No longer depends on: 311657
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.