Closed Bug 388283 Opened 17 years ago Closed 17 years ago

minimonth needs refresh to display all days of a recurrence bold

Categories

(Calendar :: Calendar Frontend, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: Fallen)

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- create a daily recurrence

RESULT:
=======

- the minimonth shows only the first day of this events in bold
- clicking the minimonth updates the view

EXPECTED RESULT:
================

- all days of this recurrence should bold immediately 

REPRODUCIBLE:
=============

- always
Summary: minimonth needs refresh to dislay all days of a recurrence bold → minimonth needs refresh to display all days of a recurrence bold
This patch fixes the minimonth for recurring events. This also required a change to the storage provider, since the notifier onModifyItem has always been called with an occurrences parentItem and the old occurrence. This patch changes to notify with the parentItem of both the new and old item.
Attachment #276616 - Flags: review?(daniel.boelzle)
Status: NEW → ASSIGNED
Comment on attachment 276616 [details] [diff] [review]
Fix for recurring events

>Index: calendar/providers/storage/calStorageCalendar.js
>@@ -442,16 +443,17 @@ calStorageCalendar.prototype = {
>         // Ensure that we're looking at the base item
>         // if we were given an occurrence.  Later we can
>         // optimize this.
>         if (aNewItem.parentItem != aNewItem) {
>             aNewItem.parentItem.recurrenceInfo.modifyException(aNewItem);
>         }
> 
>         aNewItem = aNewItem.parentItem;
>+        aOldItem = aOldItem.parentItem;

IMO a rather minimal invasive fix. With respect to coming offline sync, I'd favor a proper fix so that a modifyItem(newOccurrence, oldOccurrence) actually notifies the new *occurrence* to both calIObserver and calIOperationListener. But this should be a follow up bug; for now that mini fix makes the situation a little better.

rest is just fine, r=dbo
Attachment #276616 - Flags: review?(daniel.boelzle) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070818 Calendar/0.7pre
Status: RESOLVED → VERIFIED
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: