Keyboard navigation keys do not work in rich-textbox (javascript)

RESOLVED DUPLICATE of bug 386189

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 386189
11 years ago
11 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
When entering information into a rich-textbox, I cannot use any of the standard keyboard navigation keys (home, end, pgup, pgdn, arrows).  I can only reproduce this in Ubuntu 7.04 using the latest nightly trunk.  I remember this working a few days ago, so I will go back and try to find when it regressed.

Steps to Reproduce:
1. Using Ubuntu 7.04 and the latest nightly trunk, navigate to gmail or qmo
2. Put the focus on the rich-textbox.
For gmail, use the content box for a new email message
For qmo, use the body box for a new forum post
3. Type in gibberish (a couple pages worth is good so you can test pgup, pgdn)
4. Try to use the keyboard navigation keys

Actual Result:
Keyboard navigation keys are unresponsive

Expected Result:
Keyboard navigation keys should perform their designated function

Reproducible:
Always

I have had this bug tested on Mac OSX, Vista, WinXP SP2, Fedora 7, and 2 different Ubuntu 7.04 installs (one on my laptop, one on a QA lab computer).  This bug can only be reproduced on the Ubuntu 7.04 installs.

I am currently working on a regression window.
(Reporter)

Updated

11 years ago
Component: General → Keyboard: Navigation
Product: Firefox → Core
QA Contact: general → keyboard.navigation
(Reporter)

Comment 1

11 years ago
This appears to have regressed between 2007062705 (works) and 2007062804 (doesn't work).

Comment 2

11 years ago
With that regression range, that would mean that contentEditable regressed this, making it a dupe of bug 386189.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386189
You need to log in before you can comment on or make changes to this bug.