Back button doesn't recognise initial URL window is opened with

RESOLVED DUPLICATE of bug 18808

Status

()

RESOLVED DUPLICATE of bug 18808
11 years ago
10 years ago

People

(Reporter: greg.webb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

When opening a new window, either by Ctrl-N or opening a link in a new window, it displays fine. However, whatever page is then browsed to gets recognised as the first in the browsing history, not the one that was initially loaded - meaning the Back button (or keyboard shortcut equivalents) cannot take the user back to the original page.

Reproducible: Always

Steps to Reproduce:
1. Open new window
2. Click on link or bookmark in new window
3. Try to click on 'Back' button - still ghosted out however. Alt-left has the same effect.

Actual Results:  
The browser should return to the previous URL

Expected Results:  
The browser stayed where it was

Default theme. Extensions - Chris Pederick's WebDev toolbar, StumbleUpon, Flashblock, HTML Tidy.

Comment 1

11 years ago
i cannot reproduce... does the same happen in Safe Mode? (http://kb.mozillazine.org/Safe_Mode)
This was fixed temporary on trunk I believe by Bug 234455 but later on it broke again in a different way. I believe by Bug 335251. There are at least two dupes.
Whiteboard: [DUPEME]
Sorry, I meant the extension HTML Validator broke again. Hopefully the author can repair it.

Comment 4

11 years ago
So is this caused by Html Tidy extension?

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 18808

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.