Gracefully handle multiple simultaneous authentication dialogs needing my attention

RESOLVED DUPLICATE of bug 348997

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 348997
11 years ago
4 years ago

People

(Reporter: Håkan Waara, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
A very common situation, especially in these days of session restore blessing and multiple tabs, is that many pages need you to authenticate at the same time.

Every time I fire up my Firefox, with say 10-15 tabs, I'm greeted with around 6 overlapping dialogs that need me to write my username and password. (Sometimes a modal dialog on another screen is blocking the input of whatever dialog I'm currently seeing, but that's another bug report.)

Somehow I feel that this is neither the most user-friendly way to handle the situation, and nor very secure. 

Somehow Firefox should merge some of these authentication dialogs (maybe all that are really for the same domain - but coming from different tabs) or at the very least pop them up in some sensible order/priority.

Some new thinking might be needed to make this kind of situation less awful when *lots* of people, especially corporate users with their intranets, face this daily.

Maybe tab-specific modal dialogs would save the problem. Unfortunately such dialogs do not exist on any platforms I'm aware of.
Definitely a dupe.
Whiteboard: DUPEME
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348997
(Reporter)

Comment 3

11 years ago
Are you sure it's a dupe? I would like the situation to improve when there are simultaneous prompts from *different* sources as well.

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.