margin-top of first-child of a multi-column element having border-top not rendered

RESOLVED DUPLICATE of bug 616722

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 616722
11 years ago
4 years ago

People

(Reporter: Eli Friedman, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
data:text/html,<div style="-moz-column-count:1; border:solid"><div style="margin-top:10em">asdf

Expected results:
There is a 10em margin before "asdf".

Actual results:
There is no margin before "asdf".
OS: Windows XP → All
Hardware: x86 → All

Comment 1

7 years ago
margin-collapsing should not happen in this context, see bug 616722 comment 8
Summary: Margin-collapsing broken with parent with columns and border → margin-top of first-child of a multi-column element having border-top not rendered

Updated

6 years ago
Blocks: 684062

Comment 2

5 years ago
Hello,

When I try the test in URL field, I get a 10em (160px) top margin above "asdf".

I am using
Firefox 22.0, buildID 20130620121849, Linux KDE 4.10.4, i686 (32bits), kernel version 3.8.0-25-generic.

WORKSFORME

I have verified with 1 other test 
(
eg
http://test.csswg.org/suites/css3-multicol/nightly-unstable/html4/multicol-margin-001.htm
you must manually insert the following declarations
    -moz-column-count: 3;
    -moz-column-gap: 0px;
into the inspector style of web developer tools
and then compare with its reference file:
http://test.csswg.org/suites/css3-multicol/nightly-unstable/html4/reference/multicol-margin-ref.htm
) 
where the first block child of a multi-column element has a margin-top and it is rendered as expected.

Gérard

Comment 3

4 years ago
Just checked it.

This was fixed by bug 616722.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616722
You need to log in before you can comment on or make changes to this bug.