Last Comment Bug 388704 - drop XPointer support
: drop XPointer support
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XML (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla1.9.1
Assigned To: Robert Sayre
:
Mentors:
http://youtube.com/watch?v=zy1BmQNMSTg
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 16:58 PDT by Robert Sayre
Modified: 2011-01-26 18:53 PST (History)
20 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Robert Sayre 2007-07-18 16:58:43 PDT
We implemented it, but authors don't write it. See URL for more information.
Comment 1 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2007-07-18 18:21:20 PDT
I guess this depends on bug 32832 getting fixed ;)
Comment 2 Peter Van der Beken [:peterv] 2007-07-19 03:34:40 PDT
(In reply to comment #0)
> We implemented it, but authors don't write it. See URL for more information.

It'd be nice to have some more information though, any codesize numbers? It doesn't look very big to me. Not arguing against this removal but it's not the slam dunk that webservices was imho.
Regarding authors, I think this would be useful for extension developers if they had an easy way to generate XPointers from DOM ranges. Hopefully an extension based on http://xpointerlib.mozdev.org/ (integrated with the code from bug 319768) together with extension dependencies will make this possible in the future.

(In reply to comment #1)
> I guess this depends on bug 32832 getting fixed ;)

Not really, that's a bug for the xpointer() scheme. We do have the XPointer framework and a couple of other schemes (iirc element, xmlns, xpath) in the tree. This bug should probably be about dropping XML pointer support, which would be the XPointer framework and the schemes we implemented and the FixPtr support.
Comment 3 Robert Sayre 2007-07-19 09:13:20 PDT
(In reply to comment #2)
> (In reply to comment #0)
> > We implemented it, but authors don't write it. See URL for more information.
> 
> It'd be nice to have some more information though, any codesize numbers? It
> doesn't look very big to me. Not arguing against this removal but it's not the
> slam dunk that webservices was imho.

Definitely not going to have the huge codesize win, but it will remove code from nsDocument, nsXMLDocument, and nsPresShell.

Comment 4 Jeff Schiller 2007-10-10 08:44:52 PDT
It would love to use XPointer URL fragments in XHTML (Bug 159716) and HTML documents and to see cool things in the browser like Bug 159716.  I think this could be a differentiator for Firefox if it was usable on the existing web today... Imagine:  here's a link that goes to the first occurence of "foobar" on the web page...

http://blog.codedread.com/archives/2007/10/09/397/
Comment 5 Jeff Schiller 2007-10-10 08:46:25 PDT
Sorry, that first Bug reference should be to Bug 235409 ("XPointer element scheme doesn't work with XHTML media type")
Comment 6 Chapman Flack 2008-02-22 12:35:18 PST
Can I cast negative votes?  I really think it would be shortsighted to drop
this support.  "We implemented it, but authors don't write it" seems to miss
the point that XPointer, if implemented and usable, is something that
anybody can use, even just in sending a URL to Mom, to point into the
relevant part of a document even when the author took no special steps
to facilitate that.  And low utilization so far can also reflect that
its support in FF and SeaMonkey hasn't been very well publicized, there
haven't been examples (other than testcase attachments on bugzilla
reports) offered to show what you can do with XPointer and how easy
it is, and (this is big) it doesn't work yet in the very most common
content types that people would send links to Mom into (Bug 235409).

That makes it seem pretty premature to talk about DROPPING the support.
Comment 7 Robert Sayre 2008-02-22 12:38:14 PST
(In reply to comment #6)
> Can I cast negative votes? 

There's no voting. We welcome comments that provide new information, but we don't welcome voting and dogpiling. It's too easy to game for niche features.

So, please restrict comments to those which add new information.

Comment 8 Boris Zbarsky [:bz] 2009-03-05 20:25:32 PST
Note bug 159716, which was mentioned above.  It doesn't have to be xpointer for that use case, and it can't be until we support xpointer on HTML, but it'd be really nice to have something that fills that need that Places or extensions could build on...  I've wished for something like that several times recently, and it's come up in a few contexts for others.
Comment 9 Boris Zbarsky [:bz] 2011-01-26 18:53:43 PST
OK, so it looks like we never actually moved the xpointer impl into mercurial.  We've now shipped 1.9.1, 1.9.2, and about to ship 2.0 with no xpointer support.  I think we can consider this fixed.  ;)

Bug 457102 covers the dead-code removal.

Note You need to log in before you can comment on or make changes to this bug.