filetype-handling does not work with some files/urls

RESOLVED DUPLICATE of bug 285976

Status

()

defect
RESOLVED DUPLICATE of bug 285976
12 years ago
11 years ago

People

(Reporter: nehedix, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

I have configured FF to open PDF always in Adobe Reader (not with the adobe-plugin, but in an external app/window - Adobe Reader).
Most time I click a PDF-link FF downloads the PDF and correctly openes it afterwards in Adobe Reader.
But sometimes it askes me what to do with that file (open, save ..) with default-action "open in Adobe Reader", even though the field "always use this action" (sorry for translation, I use german-language version of FF) is clicked FF askes for filehandling from time to time (for some urls/files).
I have the same problem with .torrent-files I want to be handled by Azureus always, but FF mostly askes what to do.

Reproducible: Sometimes

Steps to Reproduce:
1. http://www.filmstarts.de/produkt/49658,Zombie%20King%20And%20The%20Legion%20Of%20Doom.pdf

Actual Results:  
asking what to do with filetype PDF

Expected Results:  
opening in Adobe Reader as set in the options

Comment 1

12 years ago
That file is being served with the following http header:

content-disposition: attachment; filename=Zombie%20King%20And%20The%20Legion%20Of%20Doom.pdf

which is a header designed specifically for non-automated further action of the user and it's likely the other times you've seen this happen have also used that header.

From https://bugzilla.mozilla.org/show_bug.cgi?id=285976#c4

"Currently, selecting "always do this" when a file is sent with the
"Content-disposition: attachment" header results in the value of the checkbox
being ignored, since the header indicates that "[the content's] display should
not be automatic, but contingent upon some further action of the user" [rfc
2183] and doing something automatically would violate that."

DUPEME to bug 285976
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 285976
You need to log in before you can comment on or make changes to this bug.