Download Manager window remains empty

VERIFIED FIXED in mozilla1.9alpha7

Status

()

Toolkit
Downloads API
--
critical
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Peter6, Assigned: sdwilsh)

Tracking

Trunk
mozilla1.9alpha7
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072211 Minefield/3.0a7pre ID:2007072211

repro:

open FF
start a download
open DM

result:
The download is not displayed at all

Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.createStatement]
Source file: chrome://mozapps/content/downloads/downloads.js
Line: 443

regression from Bug 385875
(Reporter)

Comment 1

11 years ago
after you have downloaded something, which process you can follow with win explorer it gives the following error when you close the useless DM window:
Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]
Source file: chrome://mozapps/content/downloads/downloads.js
Line: 515
(Assignee)

Comment 2

11 years ago
Created attachment 273323 [details] [diff] [review]
v1.0

d'oh

This should do the trick
Assignee: nobody → sdwilsh
Status: NEW → ASSIGNED
Attachment #273323 - Flags: review?(mano)
(Assignee)

Comment 3

11 years ago
(In reply to comment #1)
> after you have downloaded something, which process you can follow with win
> explorer it gives the following error when you close the useless DM window:
> Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)
> [nsIObserverService.removeObserver]
> Source file: chrome://mozapps/content/downloads/downloads.js
> Line: 515
expected since it never adds those because it fails before then

(Assignee)

Comment 5

11 years ago
Sorry about that...

Checking in toolkit/mozapps/downloads/content/downloads.js;
new revision: 1.68; previous revision: 1.67
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M7
(Reporter)

Comment 6

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072215 Minefield/3.0a7pre ID:2007072215

Thanks Shawn
->VERIFIED
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.