If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Today Pane: Border is too thick in events section

VERIFIED FIXED in 0.7

Status

Calendar
Lightning Only
--
enhancement
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Pete Riley, Assigned: Michael Büttner (no reviews TFN))

Tracking

unspecified

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: 

Please reduce or remove the thick borders in the events section of the Today Pane.  It would be nice if these borders looked the same as those in the tasks section.

Benefits:

1) We could display one or two additional characters of every event title in the list.  This would be a significant enhancement because of the limited space in the Today Pane.

2) It would more closely match the screenshot in Christian's design spec at http://wiki.mozilla.org/Calendar:Mail_View_Integration

Screenshot coming...

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 273445 [details]
screenshot
(Assignee)

Comment 2

10 years ago
Created attachment 273566 [details] [diff] [review]
patch v1

The agenda- and task-panel is wrapped inside a groupbox, which seems to be superfluous. If we need some padding around these elements, we should introduce a separate class instead of inheriting the 5px border that groupboxes giving us. Therefore this patch just removes these unnecessary elements from the tree.
Attachment #273566 - Flags: review?(Berend.Cornelius)
Assignee: nobody → michael.buettner
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 273566 [details] [diff] [review]
patch v1

Mickey, you forgot to remove the CSS rule also from winstripe.
(Assignee)

Comment 4

10 years ago
(In reply to comment #3)
> Mickey, you forgot to remove the CSS rule also from winstripe.
Ups, shame on me. Berend, just imagine that I did that.
Status: NEW → ASSIGNED

Comment 5

10 years ago
in reply to comment #3
In your patch you removed the groupboxes. However in the specification http://wiki.mozilla.org/Calendar:Improving_the_Calendar_Views you can see that there are boxes intende with a ThreeDShadow border around the agenda-pane and the todo-pane as well, which is why I implemented them. I agree that with the current agenda-pane this border does not harmonize and consumes too much width, yet I am not very happy that it vanishes from the sourcecode, because it will be needed in a later version again. Instead you could just replace the groupboxes with normal boxes without borders. 
Yet this implementation resolves the issue and I do not want to keep it back.

Comment 6

10 years ago
Comment on attachment 273566 [details] [diff] [review]
patch v1

review granted
Attachment #273566 - Flags: review?(Berend.Cornelius) → review+

Comment 7

10 years ago
I think this Bug should be resolved with Bug 389854 !
A side effect is, that patches aren't get in conflict like this Bug and Bug 388414 (ID's of agendapanel and todopanel). 
Or not?
(Assignee)

Comment 8

10 years ago
I would like to keep the patches as small as possible and only address a single well-defined issue per bug. Of course, giant massive patches don't run easily into conflicts but they change a ton of stuff with a single check-in. Well, you're right, Bug #389854 will break if this one gets checked-in, but this is a) resolved in less than 5 minutes and b) shouldn't be part of Bug #389854 in the first place. 

Furthermore, I just wrote this patch to bring this in now, as Berend will be on vacation for the next 2 weeks. Otherwise, we have to wait until he finishes off Bug #389854.

Comment 9

10 years ago
(In reply to comment #8)
> I would like to keep the patches as small as possible and only address a single
> well-defined issue per bug. Of course, giant massive patches don't run easily
> into conflicts but they change a ton of stuff with a single check-in. Well,
> you're right, Bug #389854 will break if this one gets checked-in, but this is
> a) resolved in less than 5 minutes and b) shouldn't be part of Bug #389854 in
> the first place. 
> 
> Furthermore, I just wrote this patch to bring this in now, as Berend will be on
> vacation for the next 2 weeks. Otherwise, we have to wait until he finishes off
> Bug #389854.

Okay, accepted ;-)

(Assignee)

Comment 10

10 years ago
patch checked in on trunk and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7

Comment 11

10 years ago
Verifeid in lightning 2007073103 -> task is fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.