Can't edit RSS feed properties in Thunderbird

RESOLVED DUPLICATE of bug 388919

Status

RESOLVED DUPLICATE of bug 388919
11 years ago
7 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072409 Minefield/3.0a7pre
Build Identifier: Thunderbird 2.0.0.5

I can't edit the properties for some of the feeds I've subscribed to in Thunderbird.  This does not happen for all of the feeds, but for those that it does, it happens consistently.  I've noticed this in Thunderbird 2.0.0.4, and it's still there in 2.0.0.5.

I have noticed the following error in Error Console:

Error: currentFolder has no properties
Source File: chrome://messenger-newsblog/content/feed-subscriptions.js
Line: 621

The offending line is marked in the URL for this bug.

Reproducible: Always

Steps to Reproduce:
1. Right click on my feeds folder account, and choose "Subscribe...".
2. Expand a feed under Slashdot (for which the problem happens) and select it.
3. Click "Edit".
Actual Results:  
Nothing happens.

Expected Results:  
The feed properties edit dialog should open.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0
(Reporter)

Comment 1

11 years ago
Created attachment 273551 [details]
feeds.rdf from the tested profile

OK, this seems to be related to bug 388919.  Here is the feeds.rdf file from the profile I have seen this bug in.

Checkout the entry for the slashdot feed I saw this bug on:

  <RDF:Description RDF:about="http://rss.slashdot.org/Slashdot/slashdotLinux"
                   dc:title="Slashdot: Linux"
                   NS1:link="http://linux.slashdot.org/" />

instead of what it should possibly look like:

  <fz:feed RDF:about="http://rss.slashdot.org/Slashdot/slashdotLinux"
                   dc:identifier="http://rss.slashdot.org/Slashdot/slashdotLinux"
                   fz:quickMode="true"
                   dc:title="Slashdot: Linux"
                   NS1:link="http://linux.slashdot.org/">
    <fz:destFolder RDF:resource="mailbox://nobody@News%20%26%20Blogs-2/ce6e393b"/>
  </fz:feed>
(Reporter)

Comment 2

11 years ago
Changing the RDF:Description element to the fz:feed element manually in the feeds.rdf file (as noted in comment 1) fixes the problem mentioned in comment 0.

Marking this bug dependent on bug 388919.
Depends on: 388919

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 2.0 → 1.8 Branch

Comment 3

7 years ago
see bug 388919 comment 26.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 388919
You need to log in before you can comment on or make changes to this bug.