Old charts display resolution and status in English

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: ycombarnous, Assigned: gerv)

Tracking

x86
Windows XP

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: 

When changing the label of status and resolution in field-descs.tmp.html, the new labels are not displayed in reports.cgi output.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

11 years ago
Version: unspecified → 3.0
(Reporter)

Comment 1

11 years ago
Strangely enough, the template code says:

"We cannot use translated statuses and resolutions from field-descs.none.html
because old charts do not distinguish statuses from resolutions."

But what about doing:

[% FOREACH dataset = datasets %]
   <option value="[% dataset.value FILTER html %]:"
       [% " selected=\"selected\"" IF dataset.selected %]>
       [% result = status_descs.${dataset.value} ? status_descs.${dataset.value}: get_resolution(dataset.value) %]
       [% result FILTER html %]
    </option>
[% END %]

What remains to be done is to have the labels in the destination chart also translated. Apparently, normal charting can do that, so there should be an easy way.
(Reporter)

Comment 2

11 years ago
In addition, the word bug is still hard-coded in old charts.

Comment 3

11 years ago
The comment explains why this would be a hack. We decided to leave old charts alone as we plan to remove them anyway, see bug 232113.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.