square in Bind DN field instead national sign

RESOLVED FIXED in mozilla1.9

Status

RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: xj, Assigned: standard8)

Tracking

unspecified
mozilla1.9
x86
Windows XP
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: 2.0.0.5 (20070716)

When I put some national sign like "ł,ó,ń" etc (in Polish) then it's change to squere or somthing difrent, so then I can't use LDAP.

Sory for my english, this my first post in that language.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
polish letter in Bind DN field
(Reporter)

Updated

12 years ago
Summary: square in Bind DN filed instead national sign → square in Bind DN field instead national sign
(Assignee)

Comment 1

11 years ago
Confirming and taking, this should be a simple fix that'll help international users.
Assignee: nobody → bugzilla
Status: UNCONFIRMED → NEW
Component: Address Book → MailNews: Address Book
Ever confirmed: true
Product: Thunderbird → Core
QA Contact: address-book → addressbook
(Assignee)

Comment 2

11 years ago
Created attachment 319546 [details] [diff] [review]
The fix

The fix - change Auth DN (aka Bind DN) setting to be an AUTF8String. Includes xpcshell test to ensure correct setting/retrieval of pref.

We haven't got facilities to test talking to LDAP servers at the moment, but I have tested on my local server with a non-ascii Bind DN and it all works correctly (the LDAP back end was been designed with this in mind apparently: http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/directory/xpcom/base/public/nsILDAPConnection.idl&rev=1.22&mark=63#50).
Attachment #319546 - Flags: superreview?(neil)
Attachment #319546 - Flags: review?(neil)

Updated

11 years ago
Attachment #319546 - Flags: superreview?(neil)
Attachment #319546 - Flags: superreview+
Attachment #319546 - Flags: review?(neil)
Attachment #319546 - Flags: review+
(Assignee)

Comment 3

11 years ago
Patch checked in, fixed (this will be in the next major version of Thunderbird/SeaMonkey).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9
(Assignee)

Updated

11 years ago
Flags: in-testsuite+
Product: Core → MailNews Core
(Assignee)

Updated

10 years ago
Duplicate of this bug: 465905
(Assignee)

Updated

10 years ago
Duplicate of this bug: 466400
You need to log in before you can comment on or make changes to this bug.