Scrollbar dragging broken when using fullZoom != 1.0

RESOLVED FIXED

Status

()

Core
Layout: Misc Code
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Sylvain Pasche, Assigned: Eli Friedman)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Steps to Reproduce:
1. Change the fullZoom on a page, so that you can see horizontal/vertical scrollbars. I used "getBrowser().markupDocumentViewer.fullZoom = 2" in the JavaScript Shell.
2. Try to scroll horizontally/vertically by dragging the scrollbar
3. See how the scrollbar does not follow the mouse movements.

I could reproduce this on Windows and Linux, so that should be a rather cross-platform issue.

Comment 1

10 years ago
It does kind of work, but you have to drag further until something happens. If you grab the vertical scrollbar and move it to the bottom, nothing happens at first. But as you drag further to the bottom, the page starts scrolling.

By the way, I use this in Firefox's error console:
top.window.opener.getBrowser().markupDocumentViewer.fullZoom = 2;
(Assignee)

Comment 2

10 years ago
Created attachment 274065 [details] [diff] [review]
Patch

I'm not sure where exactly that math was messing up, but I don't really care.
Assignee: nobody → sharparrow1
Status: NEW → ASSIGNED
Attachment #274065 - Flags: review?(roc)
Attachment #274065 - Flags: superreview+
Attachment #274065 - Flags: review?(roc)
Attachment #274065 - Flags: review+

Updated

10 years ago
Keywords: checkin-needed
(Assignee)

Comment 3

10 years ago
Please don't add checkin-needed to my bugs... the reason I haven't checked this in is that the tree is closed.
Keywords: checkin-needed
(Assignee)

Comment 4

10 years ago
Comment on attachment 274065 [details] [diff] [review]
Patch

Patch makes scrollbars use standard utility method to calculate coordinates; unlikely to cause regressions.
Attachment #274065 - Flags: approval1.9?
(Assignee)

Updated

10 years ago
Component: GFX → Layout: Misc Code
QA Contact: general → layout.misc-code
Comment on attachment 274065 [details] [diff] [review]
Patch

a19=dbaron
Attachment #274065 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 6

10 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 391391
You need to log in before you can comment on or make changes to this bug.