Password Manager does not save some passwords

RESOLVED INVALID

Status

SeaMonkey
Passwords & Permissions
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Paul Tharagonnet, Unassigned)

Tracking

({regression})

SeaMonkey 1.1 Branch
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070716 SeaMonkey/1.1.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070716 SeaMonkey/1.1.3

Newly installed XP with SP2 and downloaded newest Sea Monkey (formerly had 1.1.2) and a site which formerly worked with password manager (the above site) no longer prompts for a store of the password.  The site does not appear to have changed their software (although it may be tough to be sure) and under 1.1.2 I had my passwords wonderfully stored, now I have to type in account / password every time I visit.

Reproducible: Always

Steps to Reproduce:
1. Visit the site 
2. Make up a 9 digit account (they all seem to begin with a 4) and a password
3. Password Manager should prompt to store - on my PC not ...
Actual Results:  
Got logged in but no prompt to store

Expected Results:  
A prompt to store
Assignee: dveditz → nobody
Can you reproduce with SeaMonkey v1.1.9 ?
Version: unspecified → SeaMonkey 1.1 Branch
Paul emailed me:
{{
Yes - it´s still the case with the latest version ...
}}

*****

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9] (release) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070515 SeaMonkey/1.5a] (nightly) (W2Ksp4)

With a new profile, I can reproduce (with faked id+pw).

But this behavior is not a bug:
page source shows |<input type='password' autocomplete='off' ...|,
then you would need |wallet.crypto.autocompleteoverride = true| preference.

R.Invalid

If SM v1.1.2 did save the password (without setting the pref.), then *it* was broken.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: regression
Resolution: --- → INVALID
(Reporter)

Comment 3

10 years ago
Thanks - I never thought to check the source code because the source must have changed about the same time as I updated a Sea Monkey version and I assumed it was Sea Monkey ;-}
You need to log in before you can comment on or make changes to this bug.