If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash loading certain PNG when default charset is UTF-8 [@ nsStyleContext::Destroy()]

RESOLVED DUPLICATE of bug 389663

Status

()

Core
ImageLib
--
critical
RESOLVED DUPLICATE of bug 389663
10 years ago
10 years ago

People

(Reporter: dolphinling, Unassigned)

Tracking

({qawanted, regression, testcase})

Trunk
x86
Linux
qawanted, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
2007-07-26 linux trunk nightly

When loading http://people.mozilla.com/~faaborg/files/granParadisoUI/urlFormattingIdea2.png with a default charset of UTF-8, I crash. When loading with a normal default charset, I don't crash.

The image must be loaded alone (i.e., not embedded in a page), and must not be cached for the crash to occur.

This problem is Linux only. Sample breakpad: http://crash-stats.mozilla.com/report/index/62884d94-3c00-11dc-ac86-001a4bd43ed6?date=2007-07-27-05

I don't know if this is a regression or not.
(Reporter)

Comment 1

10 years ago
Doesn't crash in 2.0. Does crash loaded from local disk. Doesn't crash with other pngs.

qawanted for regression range, and to verify that I'm not insane seeing a bug with this many specific things needed (although based on breakpad data, others have seen it too).
Keywords: qawanted, regression, testcase
Confirmed on OS X as well with today's nightly with https://bugzilla.mozilla.org/attachment.cgi?id=274009

Flags: blocking1.9?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389663

Updated

10 years ago
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.