Yahoo mail javascript events producing incorrect dialog

VERIFIED FIXED in mozilla1.9alpha7

Status

()

defect
P2
normal
VERIFIED FIXED
12 years ago
5 months ago

People

(Reporter: marcia, Assigned: jst)

Tracking

({regression})

Trunk
mozilla1.9alpha7
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/200707270404 Minefield/3.0a7pre.

1. In regular Yahoo mail account, click on either "Empty Bulk" or "Empty Trash."
2. Receive the attached screenshot.

This appears to be a recent regression, as I check Yahoo mail every day as part of my smoketest.
This is almost certainly mine.
Assignee: general → mrbkap
Just wanted to add that click on either the OK or cancel button renders this strange error in the Error console: Error: uncaught exception: Permission denied to set property Window.safariReturnValue. Just thought the error was interesting since it mentions safari.
Hey Johnny, this might be yours (I see this, even when I disable my wrappers).
Assignee: mrbkap → jst
Component: JavaScript Engine → DOM
Flags: blocking1.9+
OS: Mac OS X → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → mozilla1.9 M7
Attachment #274842 - Flags: superreview?(jonas)
Attachment #274842 - Flags: review?(mrbkap)
Attachment #274842 - Flags: review?(mrbkap) → review+
Attachment #274842 - Flags: superreview?(jonas) → superreview+
Fixed.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
I am running the Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/200708020808 Minefield/3.0a7pre build and I still see the issue in Yahoo mail.
Marcia, this works correctly for me on Win32, and for mrbkap on both Linux and Mac. Can you please double-chec that you have a build from today and report back whether you're still seeing this problem?
I have attached the two screenshots, my other comment didn't take. It looks like the "undefined" error is gone in today's nightly, but the dialog styling seems off. See Comment 8 and Comment 9 for screenshots.
That's because we're showing a different type of dialog: before, they were using a more limited API to ask the question. Now, they're using showModalDialog and because of that, they control the styling. So, this is really the expected behavior.
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/200708020808 Minefield/3.0a7pre, based on Comment 11.
Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.