Determine proper behavior with for unregistered OS protocol handling

RESOLVED DUPLICATE of bug 392964

Status

defect
RESOLVED DUPLICATE of bug 392964
12 years ago
3 years ago

People

(Reporter: cmtalbert, Unassigned)

Tracking

Trunk
x86
Windows XP
Dependency tree / graph
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

12 years ago
After the fix for bug 389632 lands, an unregistered OS protocol will be a situation that is captured by our protocol handling code.  We need to understand what would be best to handle this case.  The current behavior is to show an alert dialog that states: "Firefox can't open this address because the protocol <protocol_name> is not registered with any application".  

This is exactly where the protocol handling infrastructure should step in and allow the user to pick an application or a webservice to open this protocol with.

== Steps To Reproduce ==
1. Ensure you have the fix for bug 389632
2. Open Firefox and type in "foo://openme.mytype" in the URL bar

== Actual Results ==
You get the afore mentioned error message

== Expected Results ==
It seems that we could be more helpful than this simple error message and offer to allow the user to use another application for the protocol handling or a web service.
Flags: blocking1.9?
The protocol handling dialog is back now from bug 389969.
This lets the user choose the application.
Depends on: 389969
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392964
No longer blocks: 372949
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.