Flash content always displayed above all elements of page.

RESOLVED DUPLICATE of bug 137189

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 137189
12 years ago
12 years ago

People

(Reporter: fabio.ornellas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)

If you use Linux + Firefox + Flash, in almost every site, the flash content is always displayed above all page elements. For example, if there is a submenu that is opened when you pass the mouse over a menu and it should open on top of a flash content, it does not. It opens below the flash content. In many sites, this breaks all interface, leaving the site completely unaccessible (due to hidden menus).

This is a Linux bug, because if you open the very same sites under Windows + Firefox + Flash, it works.

This is a very old issue, that always affected Linux, even now with the whole 9.x Flash series. I could not believe I did not find a bug already reported here.

Here is another example site:

http://www.claro.com.br/portal/site/siteTA/?epi_menuItemID=61dc49d73ce89f4b020fdda1908051a0&epi_menuID=05341fa85af675a8020fdda1908051a0&epi_baseMenuID=05341fa85af675a8020fdda1908051a0&idlocal=58

At this site and on the URL reported, the menus are opened below Flash content,  leaving content unreachable.

Reproducible: Always

Steps to Reproduce:
1. Open one of the mentioned sites.
2. Try to navigate on the menus.
3. All menus will be opened below Flash content.
Actual Results:  
Menus opened below Flash content, thus being completely unaccessible.

Expected Results:  
Menus to open above Flash content, just as it happens on the Windows version.

This issue also affect Opera + Linux + Flash at some sites. Which indicates this might be a Flash bug. However, there is a way to insert content above a Flash under Linux, as demonstrated at:

http://blog.marcoos.com/2006/07/21/html-div-above-a-flash-animation-on-linux-its-possible/

So, Firefox can render it, however, on some cases, it works only on the Windows build. There should be some fix along the code to make reddening above Flash work always when needed, just as it does under Windows.
This is already fixed on Gecko side in bug 137189. Now Adobe needs to fix their plugin.

(BTW, that's my blog ;-))
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137189
You need to log in before you can comment on or make changes to this bug.