Invalid src attribute for embed tag crashes firefox [@ libX11.so.6.2.0] [@ nsPluginNativeWindowGtk2::CallSetWindow]

RESOLVED DUPLICATE of bug 386844

Status

()

--
critical
RESOLVED DUPLICATE of bug 386844
11 years ago
7 years ago

People

(Reporter: dennisml, Unassigned)

Tracking

({crash, testcase})

Trunk
x86
Linux
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007072804 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007072804 Minefield/3.0a7pre

The following html code crashes Firefox reliably:

<html><body>
<embed src="x"></embed>
</body></html>

The culprit seems to be the "x". Putting a proper reachable document URL there (e.g. "http://some.site.com/index.html") prevents FF from crashing.


Reproducible: Always

Steps to Reproduce:
1. Load a document with the provided code

Actual Results:  
Firefox crashes
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Keywords: crash, testcase
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a7pre) Gecko/2007072705 Minefield/3.0a7pre ID:2007072705
WFM
Oops. I forgot to update my firefox. But nevertheless, also WFM:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a7pre) Gecko/2007072805 Minefield/3.0a7pre ID:2007072805
Linux only?
(Reporter)

Comment 4

11 years ago
I did some further investigation with the debugger and it seems the java plugin is to blame. For some reason the code above starts the java plugin which then crashes the browser. I updated to the latest java version 1.6.0_02 but that doesn't help. After removing the plugin from the plugins directory Firefox no longer crashes.

Comment 5

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072605 Minefield/3.0a7pre

Java gets launched for me, but I don't crash. This is very similar to bug 364235, but I'd like to use this to track the actual crash. 

Does Breakpad catch the crash? If so, can you get a Breakpad ID? http://kb.mozillazine.org/Breakpad
Component: General → Plug-ins
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → plugins

Comment 7

11 years ago
Dupe of bug 386844 per stacktrace.

0  	libX11.so.6.2.0@0x376a6
1 	libjavaplugin_nscp.so@0x11c5c
2 	libjavaplugin_oji.so@0xfca6
3 	nsPluginNativeWindowGtk2::CallSetWindow(nsCOMPtr<nsIPluginInstance>&)
4 	nsPluginHostImpl::InstantiateEmbeddedPlugin(char const*, nsIURI*, nsIPluginInstanceOwner*)
5 	nsObjectFrame::InstantiatePlugin(nsIPluginHost*, char const*, nsIURI*)
6 	nsObjectFrame::Instantiate(char const*, nsIURI*)
7 	nsObjectLoadingContent::Instantiate(nsACString_internal const&, nsIURI*)
8 	nsAsyncInstantiateEvent::Run()
9 	nsThread::ProcessNextEvent(int, int*)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Summary: Invalid src attribute for embed tag crashes firefox → Invalid src attribute for embed tag crashes firefox [@ libX11.so.6.2.0] [@ nsPluginNativeWindowGtk2::CallSetWindow]
Duplicate of bug: 386844

Updated

11 years ago
Depends on: 364235
(Assignee)

Updated

7 years ago
Crash Signature: [@ libX11.so.6.2.0] [@ nsPluginNativeWindowGtk2::CallSetWindow]
You need to log in before you can comment on or make changes to this bug.