If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

eTLD: improve Brazilian eTLD support

RESOLVED DUPLICATE of bug 370569

Status

()

Core
Networking
--
enhancement
RESOLVED DUPLICATE of bug 370569
10 years ago
10 years ago

People

(Reporter: Daniel Luz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072705 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072705 Minefield/3.0a7pre

Currently, all second-level .br domains are treated as eTLDs (set as "*.br"); however, some websites (mostly universities) do have .br domains. Also, .XX.gov.br is a special case of a third-level eTLD.

The .gov.br second-level domain is only available to Federal government entities. State entities are limited to .XX.gov.br, where XX is the state's abbreviation. This, I believe, turns it into a third-level domain. This rule is explained (in Portuguese) here: http://registro.br/faq/faq1.html#12

A few examples of domains following those rules: (eTLDs in uppercase)
registro.BR
www.cert.BR
www.unb.BR
www.mj.GOV.BR ("MJ" is not a state; it stands for Ministry of Justice)
www.SP.GOV.BR
www.metro.SP.GOV.BR

I'm providing a patch with this bug.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 274300 [details] [diff] [review]
Add all second- and third-level .br eTLDs
(Reporter)

Comment 2

10 years ago
Created attachment 274301 [details] [diff] [review]
Adding "br" to previous patch

Oops, forgot the ccTLD
Attachment #274300 - Attachment is obsolete: true
This bug is a duplicate and this patch does not adress all of the 1196 second level domains for Brazil.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370569
Also, since you can navigate to www.ba.gov.br, ba.gov.br is not a eTLD.

Only gov.br is a eTLD.

This if the official list:
http://registro.br/info/dpn.html

(Reporter)

Comment 5

10 years ago
(In reply to comment #3)
> This bug is a duplicate and this patch does not adress all of the 1196 second
> level domains for Brazil.

I don't get it. Why aren't they addressed? As I understood, "br" would be the rule applied for them all.
I've noticed the unneeded *.gov.br rules and haven't paid attention to the rest.

Well...

your patch is right without the
+ac.gov.br
+al.gov.br
...
+to.gov.br

rules.


They are not eTLD, since they're registered domains.

You can correct and attach to the other bug.



(Reporter)

Comment 7

10 years ago
While not technically top-level domains, the *.gov.br domains should be as much *effective* TLDs as Japan's geographic domains (see bug 252342 comment 31), which are currently accepted and implemented. That was my reasoning for including them. (and also, if eTLDs were just for rigorously-reserved subdomains, there would be no need for an exceptions mechanism at all; www.XX.gov.br would be the exceptions here, just like pref.____.jp are exceptions)
You need to log in before you can comment on or make changes to this bug.