Bookmarks Toolbar disappeared in organize bookmarks

RESOLVED DUPLICATE of bug 389808

Status

()

--
critical
RESOLVED DUPLICATE of bug 389808
11 years ago
9 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Was running the latest trunk and noticed my main folder in my Bookmarks Toolbar was now a feed. I went into organize bookmarks and the Bookmarks Toolbar was no where to be found. I tried to export my bookmarks from organize bookmarks and was unsuccessful. Went back to a build from a couple of days ago and successfully exported my bookmarks. Opened the exported bookmarks.html and could not find any of my bookmarks from my bookmarks toolbar. I opened the bookmarks.html in an editor and none of the bookmarks from my bookmarks toolbar were inside of it. I created a new folder in organize bookmarks and proceeded to copy the bookmarks and folders from my bookmarks toolbar into this folder in organize bookmarks. One folder copied with no contents whatsoever at which point I filed this bug. Bah!

I suspect there are multiple bugs in this bug report but there is no easy way at this time for me to differentiate them.
robert, unfortunately it sounds like you were bit by bug #389808.

there was one nightly that had a bug that removed annotations, including which folder was the personal toolbar folder.

(This bug could also convert feeds into folders, making them no longer livemarks.)

going back to an older build wouldn't help, as the annotations are lost from your places.sqlite file.

But going back to a backup of your bookmarks.html would help.  look in bookmarkbackups folder in your profile for a backup.  The checkin that caused this problem was made on 2007-07-26 09:23, so you want a backup from before that.  you can manual import it.

as for the other issue (about copy failing), that seems like a separate issue.  can you reproduce that separately (and spin off a new bug)?
Component: Bookmarks → Places
QA Contact: bookmarks → places
Thanks Seth!

I have already imported a backup of my bookmarks and went back to using a build from the 25th to avoid several of the recent regressions on the trunk. I did backup my profile so I can try to reproduce the copy bug as time permits. The bug when copying wasn't consistent... as soon as that happened I bailed on trying to fix my existing bookmarks and created a new profile.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389808
btw: since the folder that failed to copy was under the folder that was converted to a feed which was under the bookmarks toolbar that had disappeared from organize bookmarks I'm not going to bother with trying to reproduce the problem with that profile since it was rather hosed. I'll keep an eye on being able to copy folders with builds after the recent regressions have been fixed and file a new bug if I find one.
going back to the 25th will work.  when you eventually do update, you will get a complete (which includes dietrich's fix for this problem)

as for the copy folder problem, thanks for keeping an eye out.  if you see it again, let me know.

(and, sorry again about the data loss.)
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.