antialiasing inconsistent when using full page zoom

RESOLVED FIXED

Status

Core Graveyard
GFX
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Jonathan Haas, Assigned: Eli Friedman)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072805 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072805 Minefield/3.0a7pre

Bachground images are antialiased when zooming, <img>-images are not..

Reproducible: Always

Steps to Reproduce:
1. Load testcase
2. Zoom in/out (use full page zoom, not text-zoom)
Actual Results:  
<img>-Element which is not antialiased is clearly visible

Expected Results:  
There should be no square visible
(Reporter)

Comment 1

10 years ago
Created attachment 274354 [details]
testcase

Please make sure you zoom as described in Bug 4821 or use http://ted.mielczarek.org/code/mozilla/fullpagezoom.xpi
(Reporter)

Updated

10 years ago
Blocks: 4821

Updated

10 years ago
Depends on: 381661

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
(Assignee)

Comment 2

10 years ago
Created attachment 274370 [details] [diff] [review]
Patch

The cause of this is a mistake in my patch to bug 376124.
Assignee: nobody → sharparrow1
Status: NEW → ASSIGNED
Attachment #274370 - Flags: review?(vladimir)
Attachment #274370 - Flags: review?(vladimir) → review+
(Assignee)

Comment 3

10 years ago
Comment on attachment 274370 [details] [diff] [review]
Patch

Low-risk regression fix; the change only affects when anti-aliasing is used for tiled images.
Attachment #274370 - Flags: approval1.9?

Updated

10 years ago
Attachment #274370 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 4

10 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.