memory leak on attempting to download .rpm file on NT

VERIFIED DUPLICATE of bug 32741

Status

()

Core
Networking
P3
critical
VERIFIED DUPLICATE of bug 32741
18 years ago
18 years ago

People

(Reporter: Harish Singh, Assigned: Bill Law)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (WinNT; U)
BuildID:    2000041805

the mime type .rpm is wrongly recognized as a real audio file. The browser 
attempts to load the real audio plugin to play this file. I cancelled the plugin 
with the escape key.

I got the download dialog by clicking on the download link + keepign shitf 
button pressed. The download continues but the file is being copied to memory 
and will eventually run out of memory.

Reproducible: Always
Steps to Reproduce:
1. use the url above to attempt to download this .rpm file
2. browser recognizes this mime type as real audio
3. browser attempts to load real plug in
4. escape from this
5. click the download link + shift key pressed
6. brings up download dialog 
7. choose a directory to download file


Actual Results:  Use task manager to follow the memory leak. browser crashed 
when it ran out of memory

Expected Results:  download file using a buffer and refresh buffer after each 
block. 

a possible solution could be to keep a hot key combo to bring up a dialog. Let 
the user select to proceed with the default action. Also allow the mime type 
media to be downloaded for offline playback ?
Only recently got to play with Mozilla. Great work. I'd like to make more effort 
to bring this to the community.

Comment 1

18 years ago
.rpm is actually one of RealAudio's MIME types, so  if it is installed it will
"take over" the rpm types, till you tell it otherwise. However: excessive RAM
leaks have been reported earlyer when downloading - both via ftp and html, and
both on Linux and NT.
So this is likely a dup of bug 32741
Did you check what happens when you only right-click and select save?
(Without the .rpm mistake happening first I mean..)

Comment 2

18 years ago
<Assuming that Mozilla has the same behavior as NC 4.X in this area>
What is really annoying is doing this over FTP. When a file is downloaded over 
FTP, and the file has an extension that is registered on the system, the 
associated program is launched to view the file. This makes readme.doc files 
launch in Word, etc. There is no choice over FTP other than to SHIFT+Click.
Moving to the same owners and component as bug 32741. Lads - if you think this 
is a dupe, feel free :-)

Gerv
Assignee: asadotzler → law
Component: Browser-General → Networking
QA Contact: jelwell → tever

Comment 4

18 years ago
chaning status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
Yeah, I think this is a dup.


*** This bug has been marked as a duplicate of 32741 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
verified DUP of 32741
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.