hidden input is displayed when display: block, and with padding or border

RESOLVED DUPLICATE of bug 332841

Status

()

RESOLVED DUPLICATE of bug 332841
11 years ago
11 years ago

People

(Reporter: naddiseo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

340 bytes, application/x-gzip
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.5) Gecko/20070720 Ubuntu/7.10 (gutsy) Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.5) Gecko/20070720 Ubuntu/7.10 (gutsy) Firefox/2.0.0.5

Firefox displays hidden inputs if there is padding or a border set on inputs and inputs are set to display:block

Reproducible: Always

Steps to Reproduce:
1.Create a web page with a hidden input
2.set input - in css - to be display: block; padding:1px; border: 1px solid #666;
3. view page
Actual Results:  
You can see the border of the input. if border is turned off and padding on, you can see the background colour

Expected Results:  
Hidden inputs shouldn't affect the display of a page at all.
(Reporter)

Comment 1

11 years ago
Created attachment 274420 [details]
test case html page

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 332841
You need to log in before you can comment on or make changes to this bug.