spin when copying message to "Sent" folder - POP

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Marcel Berteler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no protocol log needed])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: 2.0.0.5pre 20070719

In [206408] comment# 263 Wayne asked to file a new bug. Not Sure where I can find product+component core:pop, so it is filed under General for now.

After creating and sending an email successfully using SMTP, TB can not copy the email to the "Send" folder. (In my setup copies of send emails are stored in the folder of the message I reply to. This results in the "Inbox" becoming the send folder is I create a new message vs replying to an existing one.)



Reproducible: Sometimes

Steps to Reproduce:
Not sure how to reproduce as it comes and goes.
Actual Results:  
The dialogue window stays open and TB keeps on trying to copy. This will fail eventually after along time. 

The error message asks me to re-try but selecting yes does not retry the copying. It will just go back to the compose window.

Expected Results:  
Message is copied to the "send" folder and the compose window closes.

Comment 1

11 years ago
Does it depend at all on what folder the message you're replying to? Is it possible that new mail is getting automatically retrieved to the inbox at the same time that we're trying to make a copy of the sent message in the inbox?
(Reporter)

Comment 2

11 years ago
It could be, but I have noticed that it is not always happening when new mail is being retrieved.
Maybe the first problem start when retrieval and copying is being tried at the same time, causing subsequent problems when copying other send messages.
Component: General → Networking: POP
Product: Thunderbird → Core
QA Contact: general → networking.pop

Comment 3

10 years ago
I see this too from time to time... maybe weekly.  I also store sent in the folder received... that may be a clue.

To fix, I need to exit Thunderbird, but sometimes the process is still there and must be killed with (windows) task manager, then it works again.

Robert

Comment 4

10 years ago
I am having the same problem, consistently with my POP mail. Copy to Send folder hangs up, read mail or delete mail does not function. Exiting and restarting seems to be the only fix.

Comment 5

10 years ago
(In reply to comment #1)
> Does it depend at all on what folder the message you're replying to? Is it
> possible that new mail is getting automatically retrieved to the inbox at the
> same time that we're trying to make a copy of the sent message in the inbox?

I observe similar issue with with several last releases of Seamonkey (1.1.x series, currently 1.1.13). I have 2 POP3 accounts and it happens I guess if it takes me to compose an email longer than my POP3 download interval, which is I think 2min at the moment. I guess that in the meantime the Inbox get's modified by newly arriving emails and after I send away the email I get a window saying "Copy complete" with some bar moving back and forth. I think it does not depend where is the original email placed (in which folder) or whether I am writing a new message from scratch. I think it depends on the Inbox being modified in the meantime.

Comment 6

10 years ago
if your default sent folder is set to the first radio button of sent on address@popaccount, what happens if you change it to the second radio button "other" and set to sent on address@popaccount or "sent" local folder?


I see this occasionally with if I'm heavily resource constrained in either memory or cpu and TB wants to auto save a draft - but imap

Comment 7

10 years ago
(In reply to comment #6)
> if your default sent folder is set to the first radio button of sent on
> address@popaccount, what happens if you change it to the second radio button
> "other" and set to sent on address@popaccount or "sent" local folder?

This did not help me to get rid of the "Copy complete" stale window. I think either the "too short POP3 update interval" < "time needed to compose a message"
or maybe in conjunction with my SMTP 25 (no encryption) being reachable only via a OpenVPN tunnel which sometimes breaks -- and OpenVPN does not realize that. Have to ping 10.x.x.x (the remote side) to make the tunnel working. seamonkey-1.1.13 (linux x86).
(In reply to comment #0)
> Actual Results:  
> The dialogue window stays open and TB keeps on trying to copy.
> This will fail eventually after along time. 
> The error message asks me to re-try but selecting yes does not retry the copying. 
> It will just go back to the compose window.

Similar phenomenon(slightly different from Comment #0) could be observed with next test. (Both with Tb 2.0.0.18 and Tb trunk 2008/12/14 build on MS Win-XP SP3)

(1) Create big "Unsent" folder of "Local Folders"(file name=...\Unsent Messages)
    - Copy many mails to folder X, rename \X to \Unsent Messages, restart Tb
    I tested with 40000 mails(file size=200MB).
(2) Compose a mail
(3) Delete a mail from "Unsent", and Compact folder
(4) While compaction is in progress, "Send Later" at compose window
    ==> Tb said "error occurred", and asked me for "re-try or not"
    Answer re-try => Tb said "error occurred" and asked for re-try again
    Answer re-try => Compose window was closed.
(5) Compaction normaly ended. Mail data was not found in "Unsent".

Following feature is mainly for mails filtered or moved to other mail folder than Inbox.
> copies of send emails are stored in the folder of the message I reply to
If you eager to hold all mails in Inbox, I recommend you to disable the feature, in order to reduce frequency of unwanted problems.
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

9 years ago
Duplicate of this bug: 407148

Comment 10

7 years ago
(Jack no longer using tbird)
Whiteboard: [no protocol log needed]

Comment 11

7 years ago
(In reply to Martin Mokrejs from comment #7)
> (In reply to comment #6)
> > if your default sent folder is set to the first radio button of sent on
> > address@popaccount, what happens if you change it to the second radio button
> > "other" and set to sent on address@popaccount or "sent" local folder?
> 
> This did not help me to get rid of the "Copy complete" stale window. I think
> either the "too short POP3 update interval" < "time needed to compose a
> message"
> or maybe in conjunction with my SMTP 25 (no encryption) being reachable only
> via a OpenVPN tunnel which sometimes breaks -- and OpenVPN does not realize
> that. Have to ping 10.x.x.x (the remote side) to make the tunnel working.
> seamonkey-1.1.13 (linux x86).

I still get this error with:

Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20120128 Firefox/9.0.1 SeaMonkey/2.6.1 

I still think it has to do with emails arriving in the background in my Inboxes
via POP3 while I have been composing an email some longer while. I bet I get it because
I have now lousy connection over 3G UMTS modem. POP3 fetch interval is 10 min from two different servers (one is tunneled 127.0.0.1:110, other is gmail.com via 995 SSL/TLS). Sending is via SMTP via openvpn connection to a qmail-based smtp server on port 25 (no SSL/TLS).

Just composed a 5MB large email and sent to myself over the slow line and got it again:

The message subject was "test" and it contained almost 5MB of attachments. First I saw the Sending message window with percenatges raising up. Then, I saw briefly a "Message sent ..." window and then another window afterwards popped up:

Title: Sending messages - test
Status: Copy complete.
Progress: a blue bar moving from the left to the right all the time

Only "Cancel" button offered and the window stayed until I really clicked that button.

The mail did end up in my Sent folder, has 4.9MB.

No new messages arrived meanwhile but I did manually ask mailer to check both POP3 servers. gmail.com said "No new messages" while the other via OpenVPN did not answer, probably I was sending the message out over the same OpenVPN connection so it did not make a connection. After the message was sent and I pressed the Cancel button, I could re-check the POP3 server over the OpenVPN connection and it said "No new messages" (merely I want to say the OpenVPN connection did not die or did no re-establish).

I do not know but maybe it has to do with some buffers on the network side? OpenVPN eats the data into a buffer and mailer probably think the data was already snet (a long while I see that 100% were sent). However, they were probably not sent yet physically. Could that fool seamonkey mailer?

Comment 12

7 years ago
(In reply to Martin Mokrejs from comment #11)


> I still think it has to do with emails arriving in the background in my
> Inboxes via POP3 while I have been composing an email some longer while. I bet I get

Sorry, forgot to fix the sentence. It should read "... I don't think anymore....". As I said below, I received no new messages meanwhile. However, it could be related however to the fact the POP3 server was contacted meanwhile.

Comment 13

7 years ago
(In reply to Martin Mokrejs from comment #11)


> The mail did end up in my Sent folder, has 4.9MB.

And it did arrive in my Inbox afterwards through gmail.com.

Comment 14

7 years ago
Marcel  no longer sees the problem. So we close this WFM.

Adolf, if you still see this problem we should reopen your bug 407148 (or you tag onto a different bug)

Martin, can you file a new bug for your issue please?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 15

7 years ago
sorry, I've switched from POP to IMAP. Since then I haven't seen this problem any more.

Comment 16

7 years ago
(In reply to Wayne Mery (:wsmwk) from comment #14)
> Martin, can you file a new bug for your issue please?

Opened bug #724511.
You need to log in before you can comment on or make changes to this bug.