Last Comment Bug 390298 - ATK hierarchy inconsistent for ARIA spinners
: ATK hierarchy inconsistent for ARIA spinners
Status: RESOLVED INVALID
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
: alexander :surkov
Mentors:
Depends on:
Blocks: orca
  Show dependency treegraph
 
Reported: 2007-07-31 06:49 PDT by Scott Haeger
Modified: 2007-09-24 10:08 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Scott Haeger 2007-07-31 06:49:22 PDT
This spinner http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Slider.html is an example where there are extra 'section's in the accessible tree which make up the construct of the spinner.  These accessible nodes should not be exposed in the accessible hierarchy.
Comment 1 Aaron Leventhal 2007-09-12 13:27:14 PDT
Is this the same as bug 395258. Can they somehow be merged into one bug for spinners? There is also the XUL spinner bug 365893.
Comment 2 Scott Haeger 2007-09-12 14:00:58 PDT
For my purposes this is more like https://bugzilla.mozilla.org/show_bug.cgi?id=390154 .  The problem is that there are so many accessible objects associated with this widget.  I was hoping that only a single accessible object could be exposed for a spinner.

Note: the link in the opening comment should be http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Spinner.html
Comment 3 alexander :surkov 2007-09-23 08:34:42 PDT
If I get right then 'section' accessibles shouldn't be accessible because their div nodes has 'presentation' role but those divs contains @tabindex="-1" attribute that leads nodes are focusable and therefore we expose accessbiles for them. So, invalid?
Comment 4 Aaron Leventhal 2007-09-24 10:08:51 PDT
As Surkov says, this is not a bug in Mozilla.

Scott, can you file a bug on Dojo to remove the unnecessary tabindex="-1" on those divs? It's forcing the creation of an accessible even though there is role="presentation".

Note You need to log in before you can comment on or make changes to this bug.