Closed Bug 390300 Opened 13 years ago Closed 13 years ago

Open new event dialog from the today pane -> wrong default event length

Categories

(Calendar :: Lightning Only, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: ssitter)

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- open the new event dialog with a doubleclick in the today pane (agenda area)

RESULT:
=======

- the event length is 00:00

EXPECTED RESULT:
================

- the event length should be the default (60 minutes, see 'Preferences -> Lightning -> General -> "Default Event Length")

REPRODUCIBLE:
=============

- always
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 361369
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Confirmed using Tb 2.0.0.7pre (20070817) + Lightning 0.7pre (2007081795)
on WinXP.
Flags: blocking-calendar0.7?
Assignee: nobody → Berend.Cornelius
Status: REOPENED → NEW
createEventWithDialog() will automatically calculate the correct end date from the start date and preference calendar.event.defaultlength.
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/calendar/base/content/calendar-item-editing.js&rev=1.42&mark=97-100#90
Assignee: Berend.Cornelius → ssitter
Status: NEW → ASSIGNED
Attachment #277920 - Flags: review?(daniel.boelzle)
Marking blocking 0.7 because this is bad user experience (decided on QA chat) and has already a patch.
Flags: blocking-calendar0.7? → blocking-calendar0.7+
Attachment #277920 - Flags: review?(daniel.boelzle) → review?(Berend.Cornelius)
Whiteboard: [patch in hand]
Comment on attachment 277920 [details] [diff] [review]
rev0 - omit end date when calling createEventWithDialog()

Stealing review ;). r=mschroeder

Daniel, you asked some time ago, if I want to do reviews. Here is my first one, and I hope this is okay with you.
Attachment #277920 - Flags: review?(Berend.Cornelius) → review+
No problem; checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: [patch in hand]
Target Milestone: --- → 0.7
Version: Trunk → unspecified
I asked Berend in Bug 388414 Comment #34 to incorporate the changes into his patch too because he touches the same lines of code.
Target Milestone: 0.7 → ---
Version: unspecified → Trunk
Target Milestone: --- → 0.7
Version: Trunk → unspecified
Checke in Lightning build 2007091303 -> VERIFIED
Status: RESOLVED → VERIFIED
This issue has been regressed again in 0.8pre, see Bug 418115 Comment #2 and following.
You need to log in before you can comment on or make changes to this bug.