Closed Bug 390438 Opened 14 years ago Closed 14 years ago

^ are upsetting solaris (bourne shell) /bin/sh breaking the build

Categories

(Firefox Build System :: General, defect)

All
Solaris
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 389793

People

(Reporter: timeless, Unassigned)

References

()

Details

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/content/base/test/Makefile.in&rev=1.17&mark=91,95#86

/export/home/mrbld/tinderbox/SunOS_5.11_Depend/mozilla/config/nsinstall -R test_bug5141.html test_bug51034.html test_bug218236.html file_bug218236_multipart.txt file_bug218236_multipart.txt^headers^ test_bug218277.html test_bug238409.html test_bug276037-1.html test_bug276037-2.xhtml test_bug308484.html test_bug311681.xml test_bug337631.html test_bug338541.xhtml test_bug338679.html test_bug339494.html test_bug339494.xhtml test_bug339494.xul test_bug343596.html test_bug352728.html test_bug352728.xhtml test_bug355026.html test_bug357450.js test_bug357450.html test_bug357450.xhtml test_bug357450.xul test_bug357450_svg.xhtml test_bug357509.html test_bug358660.html test_bug362391.xhtml test_bug364092.xhtml test_bug364413.xhtml test_bug366946.html test_bug367164.html test_bug371576-1.html test_bug371576-2.html test_bug371576-3.html test_bug371576-4.html test_bug371576-5.html test_bug372086.html test_bug373181.xhtml test_bug375314.html test_bug382113.html bug382113_object.html test_CrossSiteXHR.html file_CrossSiteXHR_fail1.xml file_CrossSiteXHR_fail2.xml file_CrossSiteXHR_fail2.xml^headers^ file_CrossSiteXHR_fail3.xml file_CrossSiteXHR_fail4.xml file_CrossSiteXHR_pass1.xml file_CrossSiteXHR_pass1.xml^headers^ file_CrossSiteXHR_pass2.xml file_CrossSiteXHR_pass3.xml ../../../_tests/testing/mochitest/tests/content/base/test
/bin/sh: headers: not found
/export/home/mrbld/tinderbox/SunOS_5.11_Depend/mozilla/config/nsinstall: cannot change directory to file_bug218236_multipart.txt: Not a directory
/bin/sh: test_bug218277.html: not found
/bin/sh: headers: /bin/sh: file_CrossSiteXHR_fail3.xml: not found
not found
/bin/sh: headers: not found
/bin/sh: file_CrossSiteXHR_pass2.xml: not found
gmake[6]: *** [libs] Error 1

For reference:
timeless@swift:~% uname -a
SunOS swift 5.11 snv_53 i86pc i386 i86pc
timeless@swift:~% /bin/sh
$ echo /export/home/mrbld/tinderbox/SunOS_5.11_Depend/mozilla/config/nsinstall -R test_bug5141.html test_bug51034.html test_bug218236.html file_bug218236_multipart.txt file_bug218236_multipart.txt^headers^ test_bug218277.html test_bug238409.html test_bug2760
test_bug218277.html: not found
headers: not found

This breaks both sparc and x86 (because it's the shell that's unhappy).

This works:

$ echo /export/home/mrbld/tinderbox/SunOS_5.11_Depend/mozilla/config/nsinstall -R test_bug5141.html test_bug51034.html test_bug218236.html file_bug218236_multipart.txt 'file_bug218236_multipart.txt^headers^' test_bug218277.html test_bug238409.html test_bug27
/export/home/mrbld/tinderbox/SunOS_5.11_Depend/mozilla/config/nsinstall -R test_bug5141.html test_bug51034.html test_bug218236.html file_bug218236_multipart.txt file_bug218236_multipart.txt^headers^ test_bug218277.html test_bug238409.html test_bug27

Note the single quotes around the file name containing hat (^)
Duplicate of bug 389793.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389793
Status: RESOLVED → VERIFIED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.